Device not appearing on PC

My Marantz NA 11S1 does not appear as a device when I open Spotify on my PC, it does appear as a device on my iPhone 6.  I can access Spotify directly from my NA  11S1.  The NA-11S1 can access my music library on my PC.  I have Roon and can send music to the NA-11S1 from my PC using Roon.  What needs to be done for the Spotify on my PC to see the NA-11S1?


btw:  Spotify's Idea statistics aren't all that impressive when unresolved posts are deleted after a week of inactivity which is apt to happen during vacations and/or snow storms, as happened with the original posting of this issue, ooops I mean "idea".

Hey @degnanje!


We're closing this thread as we didn’t receive an answer from you. If you're still having the same issue, just give us a shout.


All the best :)

Status: Closed

Related Issues

Status changed to: Need more info

Hi @degnanje


Thanks for getting back in touch.

We're sorry you're feeling this way and keep in mind you can always get back in touch with us. We'll be right here to help out. 


Just to check - were you able to see your Marantz NA 11S1 before on your computer? Also, are you giving it a try by Connect? In the meantime, feel free to tell us what have you tried. That would be super helpful. 


Hope to hear back from you soon.


Before what? the NA 11S1 has never appeared on when I open spotify connect on my computer.  Again I have no trouble playing Tidal through Roon on my PC, its got to be something to do with an interface between spotify and the network and/or windows 10.

Spotify Legend

Hey @degnanje


Thanks for keeping us posted.


So we can get this looked into with you, could you let us know the following info:


- Which OS are you running on the device?

- Which version of Spotify are you running on your Desktop?

- Is this happening on a home or work network?

- Are you running the newest available firmware on the device?


Also, we'd recommend checking the steps and info shown over at this link. Let us know if they help!






The Marrantz NA 11S1 is the device, its not a computer so I don't believe I have the option of running an Operating System.  I have downloaded the latest firmware for the device.

I am running the most current version of Spotify.  My previous post was deleted but in response to comments on  that posting I deleted Spotify and reinstalled it, and then confrimed the latest version.

It is a home network supported by a Comcast router, with both the PC and the NA 11S1 using ethernet to connect to the router.

Again keep in mind that its just from the PC that Spotify doesn't see the NA 11S1.  My Iphone sees it and can delegate to it.  And that other programs like Roon/Tidal can see and play to the NA11S1 from the PC.

And yes "this link" is always suggested by those responding to this post but really, I did all that before I posted the first time.


Thanks for that info @degnanje!


In this case, can you try reinstalling the app on your computer? Here's how to do it. We'd also recommend resetting your internet router to see if this makes a difference. 


Let us know how it goes.


As noted above I deleted Spotify from my computer and reinstalled it.  I have also reestablished the connection between spotify and the NA 11S1 by reloading my NA 11S1, rebooted my PC, rebooted the router,  etc, basically reinstalled everything twice only to get the same result.  Each time Roon/Tidal come through with no problem, Spotify can't see the NA 11S1 from the PC, it can see it from the iPhone.


Thanks @degnanje.


We'd like to gather as much info as possible before we can report this to our team. If it's possible, can you try using Spotify Connect with your receiver and a different computer?  


Keep us in the loop.


Yes.  I downloaded Spotify to an HP laptop, that connects via wireless to the router, and was able to play to the lap top.  On spotoify connect both computers and the iphone see each other as devices.  The iphone doesn't display the NA 11S1 as a device on the default menu, but it will appear under More Devices, however this morning, when I try to select and play to the NA 11S1 from the iphone I get and AirPlay unable to connect message, whereas I used to be able to play to it from the iphone.  I can open the NA 11S1 app on the iphone and select Spotify and play to it, just as I can open Spotify from the remote on the NA 11S1.   When I do this though the PC still says its connected to spotify and not the iphone.  I am able to connect to Spotify from the iphone/NA 11S1 and from the HP PC and play separate music to each device.  So there are "work arounds" it just seems like the NA 11S1 should appear on connect from the PC.


Thanks for the quick reply, @degnanje.


We'd like to get to the bottom of this. If possible, try to log in using a friend's account to see if this is still happening. Also, can you tell us more about the AirPlay error message you're getting? 


Keep us posted.


I do not have a friend that has a spotify account.  Screen shot attached of iphone message.