Downloading on Apple Watch stuck at first song

Hey folks,


We're receiving reports that some users are unable to download music for offline listening on their Apple Watches. The download is stuck on the first song and doesn't progress.


If you’re experiencing this issue, make sure to add your +VOTE and follow the instructions in the Status Update below.


We'll be keeping everyone up to speed here, so make sure to Subscribe to this thread. 



Hello everyone,


We want to confirm, we're still investigating this. We're gathering your reports and passing them on.


Based on user feedback and tests, we've gathered some recommendations that yield positive results, which we'd like to add to what we previously shared with you.


When attempting to download music to your watch for the first time, make sure to keep your phone as close as possible to your watch until the download of the 1st track finishes. Best to have them side by side for best results. This should only be necessary initially.


As previously mentioned the very first download is expected to take more time and stay in the 'Downloading 1 of ...' state for a few minutes, but if the watch is connected to and in close proximity to the phone with a stable network, it should start progressing after a while.


Additional troubleshooting steps we can recommend that have been reported to work are:

  • clean reinstall the app on both your smartphone and the smartwatch
  • unpair and pair the watch again
  • connect the watch to a charger
  • restart the watch
  • try a different internet connection


We’ll get back to you again when we have new info. Thank you!


It is beyond crazy that a company like Spotify have not fixed this bug yet now months later. 

Have tried all tricks on those 24 pages and still nothing. 

Only soulution is cancel subscription and move to Apple Music. 


Ive written a few times on how i got it working. Now i get nothing. Spotify on phone has the option to remove from watch, but watch has nothing to remove. Not even a stuck download. This is since the last Spotify update, you know, the one where they say ‘fixed issues and stability’ lol. 

Considering i had ti working fine, and have not doesnt any OS updates since, i cant see why it now doesn't work at all,




I still can't get this work. I've updated everything and here are the latest details:


I've deleted the apps,  tried every possible combination of having the phone on and off, only using WIFI, selecting a different WIFI (I've tried four different Wifi's in two different countries) . I also re-paired the phone with my watch once again this morning. 


Plan: Premium (family)

Country: Sweden

Phone: iPhone XR (iOS 15.2)

Apple Watch Series 6, wachOS 8.3 (19S55)  Model: MG133KS/A

Spotify Version:


Even getting spotify to stream music via the watch works so-so, it took a number of tries and restarts to sort it out, at first it refused to play more than a few seconds via the headphone (whereas other apps such as the podcast app instantly work just fine).


PLEASE HELP!!! What more can I try?




To spotify staff: are you able to re-create this problem? Is there any additional data that we could provide to iron out this bug? Anything else I could try?


As I've stated before, let me drop of my watch at your Stockholm office so that you can investigate it physically. 


I still have this problem.




Just turn off Bluetooth in you phone’s settings (not control center.) That’s all. 


Lol, thats not ‘all’ all, haven't  you read any of the posts here? 😂

Try it. That’s why I posted it. Found it on Reddit. And that’s “all all” it
took for me.

Its been tried. That’s why I asked if you have read any of this thread. You’re just re posting what’s already been posted here. 
Its been shown that there is no one fix for everyone. 


I have the same issue, I've literally tried everything with an Apple Watch Series 7...


That's super annoying.