Downloading on Apple Watch stuck at first song

Hey folks,

 

We're receiving reports that some users are unable to download music for offline listening on their Apple Watches. The download is stuck on the first song and doesn't progress.

 

If you’re experiencing this issue, make sure to add your +VOTE and follow the instructions in the Status Update below.

 

We'll be keeping everyone up to speed here, so make sure to Subscribe to this thread. 

 

Thanks! 

Hello everyone,

 

We want to confirm, we're still investigating this. We're gathering your reports and passing them on.

 

Based on user feedback and tests, we've gathered some recommendations that yield positive results, which we'd like to add to what we previously shared with you.

 

When attempting to download music to your watch for the first time, make sure to keep your phone as close as possible to your watch until the download of the 1st track finishes. Best to have them side by side for best results. This should only be necessary initially.

 

As previously mentioned the very first download is expected to take more time and stay in the 'Downloading 1 of ...' state for a few minutes, but if the watch is connected to and in close proximity to the phone with a stable network, it should start progressing after a while.

 

Additional troubleshooting steps we can recommend that have been reported to work are:

  • clean reinstall the app on both your smartphone and the smartwatch
  • unpair and pair the watch again
  • connect the watch to a charger
  • restart the watch
  • try a different internet connection

 

We’ll get back to you again when we have new info. Thank you!

Comments
Deejaycrox
Newbie

Please try the following. It works for me:

 

Here’s the exact steps I take to make it work, ensuring Apple Watch is connected to WiFi:

  1. With everything as normal (iPhone not in airplane mode, with WiFi and Bluetooth on) select a playlist to download to Apple Watch in the Spotify app on iPhone
  2. Playlist appears in the Apple Watch downloads list, in grey with “1 of x downloaded”.  This never appears to go any further.
  3. Put iPhone into Airplane mode with WiFi and Bluetooth also switched off
  4. Force close Apple Watch app
  5. Relaunch Apple Watch app
  6. Apple Watch downloads the songs over WiFi 

 

Josh_O
Newbie

Hey all,

 

I currently have the iPhone 12 pro. I just got the new 7 series watch and when I attempt to download playlists onto it from Spotify I am met with a loading screen. I am clicking “Download onto Apple Watch” on the mobile app, but the only thing I can see under downloads is “Loading…” Is there a reason for this? Or a fix?

 

I have tried uninstalling and re-installing the Spotify app on both devices. I have tried resetting both devices. I am also trying to listen to the playlist on the watch with BT headphones prior to starting the download, and I just keep getting the white blinking watch symbol on the watch, with nothing coming over the headphones..

 

Any ideas are appreciated......

 

 

 

 

 

Davebass5
Newbie

Did you try the fix i posted? If not, give it a go. 

Josh_O
Newbie

@Davebass5 It appears that this fix worked! It going very slowly, but this is the most progress I've been able to make this far. I appreciate your help! Will update with any changes...

db134
Newbie

I cannot download songs *at all*. Nothing shows up in the downloads section. It just says “loading…” forever.

This is iOS 15.1 and WatchOS 8.1 on a brand new Apple Watch 7 with cellular.

 

I have tried: removing and readding the app to my watch; removing and reinstalling the app on my iphone; turning both phone and  Watch off and on; a factory reset of my Watch.

 

This is completely frustrating. Nothing should claim to work and still be this difficult to use. (It *also* won’t let me stream on my watch even though I have cellular, which is another issue, but don’t suggest that as an alternative.)

 

1992E201-A8AC-427E-9882-B77308A7780D.png

Josh_O
Newbie

I was having the EXACT same issue earlier today.

 

@db134 I'm going to post a comment from @Davebass5 that worked for me!

 

"Did you log out before deleting the app off the phone? Doing this was the only thing i found that worked for me and my GF. Log out, uninstall, reboot both devices, and then re install."

 

So make sure to log out of the app on the phone, and then delete it off the phone. Then reboot both the watch and phone, re-install, and give it a whirl. This worked for me like 5 minutes ago. 

 

Hope it works for you too!

db134
Newbie

@Josh_O @Davebass5 Thanks for the suggestion, but I just tried it, and it’s still the same. No streaming, no downloading. Just “connecting…” and “downloading…” forever. 

Alex327
Newbie

**UPDATE**

Steps that triggered the first download for me:

 

1. Force quit Spotify app on both watch and phone.

2. Set iPhone in Airplane Mode and turn off Bluetooth and wifi from settings (so they are completely off)

3. Wait for Apple watch to connect to WiFi.

4. Launch Spotify app on Apple watch, and head to the downloads section. (Still said only 'loading...'

5. Open Spotify app phone.

6. Download starting on Apple Watch, and has now completed downloading 2 playlists. 

 

---

Just tried this and still only says 'loading...' indefinitely.. pretty frustrating as it worked flawlessly on my series 3 Apple watch a couple weeks ago, and now on series 7 it simply doesn't want to load

barrier
Newbie

I was stuck in the "loading" screen on the watch and could fix it with the following steps

 

Disabled Wifi/BT and enabled flight mode on iphone (from the settings ! not control center) - closed the watch App.

 

Restarted the Apple Watch (holding side button etc.) ... after Restart I put in Apple Watch into flight mode and disabled it afterwards.

 

Enabling Wifi/BT and disabling Flightmode on iPhone again.

Opening Spotity on iPhone.

 

Opening Spotify on Apple Watch. 

Seeing Downloads YEAH !!! 🚀

 

Downloaded 100 Songs from 2 Playlists (1 already downloaded on the iphone) within about 15 minutes.

 

I could play offline only with connected Airpods to the Watch.

 

Though it seems that the loaded music data is not reflected in the storage summary.

 

 

 

Sidenote:

iphone 12  iOS 15 / Watch 6 WatchOS 8.1

Device to device communication in wifi network is allowed

Background Synchronization is allowed for Spotify

 

Mario
Moderator
Moderator
Status changed to: Under investigation

Hello everyone,

 

We want to confirm, we're still investigating this. We're gathering your reports and passing them on.

 

Based on user feedback and tests, we've gathered some recommendations that yield positive results, which we'd like to add to what we previously shared with you.

 

When attempting to download music to your watch for the first time, make sure to keep your phone as close as possible to your watch until the download of the 1st track finishes. Best to have them side by side for best results. This should only be necessary initially.

 

As previously mentioned the very first download is expected to take more time and stay in the 'Downloading 1 of ...' state for a few minutes, but if the watch is connected to and in close proximity to the phone with a stable network, it should start progressing after a while.

 

Additional troubleshooting steps we can recommend that have been reported to work are:

  • clean reinstall the app on both your smartphone and the smartwatch
  • unpair and pair the watch again
  • connect the watch to a charger
  • restart the watch
  • try a different internet connection

 

We’ll get back to you again when we have new info. Thank you!

Related Issues