Downloading on Apple Watch stuck at first song

Hey folks,

 

We're receiving reports that some users are unable to download music for offline listening on their Apple Watches. The download is stuck on the first song and doesn't progress.

 

If you’re experiencing this issue, make sure to add your +VOTE and follow the instructions in the Status Update below.

 

We'll be keeping everyone up to speed here, so make sure to Subscribe to this thread. 

 

Thanks! 

Hello everyone,

 

We want to confirm, we're still investigating this. We're gathering your reports and passing them on.

 

Based on user feedback and tests, we've gathered some recommendations that yield positive results, which we'd like to add to what we previously shared with you.

 

When attempting to download music to your watch for the first time, make sure to keep your phone as close as possible to your watch until the download of the 1st track finishes. Best to have them side by side for best results. This should only be necessary initially.

 

As previously mentioned the very first download is expected to take more time and stay in the 'Downloading 1 of ...' state for a few minutes, but if the watch is connected to and in close proximity to the phone with a stable network, it should start progressing after a while.

 

Additional troubleshooting steps we can recommend that have been reported to work are:

  • clean reinstall the app on both your smartphone and the smartwatch
  • unpair and pair the watch again
  • connect the watch to a charger
  • restart the watch
  • try a different internet connection

 

We’ll get back to you again when we have new info. Thank you!

Comments
jlb522
Newbie
I Uninstaller the app and it fixed the issue. All good now.
Vico21
Newbie

@Ver 
I've tried everything. Still not working. Uninstalled the app on both devices, and reinstalled them again a dozen times. Reseted my watch to factory settings.
I'm using the latest version I can get (8.6.84) on an iPhone 13 and an Apple Watch Series 7.

Please don't hesitate to contact me if you want to debug it or if you need more information. I have developer knowledge so I might help you 🤗

But please don't leave us alone.

baiweimin
Newbie

My Apple watch series 7 GPS version does not play a downloaded playlist. I have premium family plan. The playlist is shown downloaded on my Apple Watch. When I try to play the playlist offline without internet, it does not play. The storage of Spotify data and document is only 32KB used. I am wondering if the playlist has been downloaded or not. 

 

It used to be working with my iPhone 8 but it is not working with my iPhone 12 Pro Max. 

Davebass5
Newbie

No, thats not right. The storage should be a lot more than that. 

Ive had a few albums that are downloaded but just wont play. Best thing to do is delete off the watch and try again. 

 

 

alexm00dy
Newbie

I've got the same problem here:

My Apple Watch won't start downloading ANY Spotify playlist. The download section (watch) keeps showing "Loading...".

I've tried almost every solution given by this thread.

 

- iPhone 7, Ver. 15.2

- Apple Watch SE, Ver. 8.3

 

I really want to listen to music without my phone...

Thanks for any advice!

 

Edit: It somehow started working. I guess one of the solutions worked.

Pindy
Newbie

Connecting both iPhone and apple watch to charger, having them next to each other and having Spotify open on both devices sometimes works for me. However, for a brand as big as Spotify working with a device as common as the Apple Watch, you would really expect better....

Deejaycrox
Newbie

Well, no amount of fiddling could persuade my Apple Watch today to play anything, despite it working for months (and indeed working at the weekend).  I am so sick of this.  I am going to have to learn how Apple Music works aren’t i?  Spotify - you have had well over a year to make this feature work properly, with feedback from me and countless other users on this thread.  This isn’t acceptable from a company who I pay a handsome annual fee for my music.

DIAMONDO98
Newbie

Hello one and all!

 

The solution that worked for me was:

 

I reinstalled Spotify on my iPhone, set a playlist to download on my Apple Watch i checked to see if anything has downloaded for the first 10 mins nothing, tried on a charger and all the suggestions from above, but i read somewhere else to turn off Bluetooth on my iPhone & making sure my watch was connected to WiFi then close and reopen the spotify app on my watch and my gosh the downloads are so fast now! I am just going to turn bluetooth off when i need to download more playlists to my Apple Watch.

 

I used to have downloads working before with Bluetooth on and they were very slow, but now the speed is unreal.

 

Cheers,

Josh

 

 

 

Deejaycrox
Newbie

The trouble I had is that downloaded tracks simply refused to play. Point blank. 

I have a six month trial of Apple Music. It was easy to switch and transfer my playlists, it’s worked perfectly first time and my watch has synched with the playlists I want straight away without any fuss whatsoever. 

 

Millionsknives
Casual Listener

Still having this problem on the most up-to-date iOS and Spotify versions. 

 

Edit: After posting this I saw DIAMONDO98's post above that suggested tuning off bluetooth on my phone, then closing and reopening the Spotify app on my watch — that worked and they've now synced.

Related Issues