[ERROR] Can't play current track

Thread #1 #2 #3

Device: Windows / OSX

 

Operating System Version: Windows 7

 

Spotify Version1.0.15.133 and more

 

Description:

 Music will stop playing with the "Can't play the current track" error message.  If you dismiss the message, music will not resume.  

 

Workaround:

Skip to the next song, music begins playing.

Pick 'Radio' from the left menu, select a genre,  music begins to play.

 

Additional information:

 N/A

 

Thanks again for all your reports regarding this issue. We’re currently investigating and will hopefully have an update soon. If you haven’t already please be sure to try the basic troubleshooting steps listed in Jim’s post over here.

 

We’re closing this thread to continue collecting reports in the largest thread. If you’ve attempted the troubleshooting but not reported your info to us, post the following information over here:

 

  • Your Spotify username (if you're comfortable sharing it publicly)
  • Your device
  • Your device's operating system
  • The Spotify version installed
Comments
jin226
Newbie

Tried the steps the moderator linked to. Tried downloading the earlier version as well. Still no dice. Spotify hasn't solved this problem for over 2 years...

Coulissen
Newbie
I think it has to do with a USB headset that I used to use. Since I bought a bluetooth headset, the issue miraculously disappeared. Not thanks to the Spotify supportteam though...
jimmypike27
Casual Listener

Tried all of these.. installed old version of Spotify with link provided and now even that isn't playing songs.. it doesn't come up with an error - there is just no sound.. this is incredibly frustrating

IvanVasilev
Newbie

This is **bleep**

IvanVasilev
Newbie

This is shi.t dont bleep me you mother **bleep**er's

 

jack_ripper_666
Newbie

 

spotify premium 1.0.80.474.gef6b503e

windows 10, version 1803

 

frequently keep getting cant play current track error

this happened after i update my windows

 

 i've tried numerous of solution but nothing works
these is the solution i've tried:

- restart the pc and spotify

- uninstall, delete every spotify folders

- reinstall back

- turn on/off hardware acceleration

- turn off crossfade

- turn on/off high quality

- untick local files

gerbensmits
Newbie

I have recently moved all music that I had on my Mac to an external harddrive. The only songs that Spotify won't play are these, even though they are on spotify and weren't just local files. 

cbujak
Newbie

I hesitate to comment on a chain this long but here goes.

Running MacOS Mojave (10.14.6) with the spotify app v1.1.27.472.gf6574b97

It seems like waking up from sleep, or switching WiFi causes the Spotify app to have this problem.

I've even had it happen when I disconnect from my Work VPN (split-tunnel, so it only routes traffic to the protected resources. Spotify should not be using this connection for anything)

 

Closing and re-launching the app will almost always fix it.

It's tiresome and tedious to have to re-launch.  

Related Issues