[ERROR] Can't play current track

Thread #1 #2 #3

Device: Windows / OSX

 

Operating System Version: Windows 7

 

Spotify Version1.0.15.133 and more

 

Description:

 Music will stop playing with the "Can't play the current track" error message.  If you dismiss the message, music will not resume.  

 

Workaround:

Skip to the next song, music begins playing.

Pick 'Radio' from the left menu, select a genre,  music begins to play.

 

Additional information:

 N/A

 

Thanks again for all your reports regarding this issue. We’re currently investigating and will hopefully have an update soon. If you haven’t already please be sure to try the basic troubleshooting steps listed in Jim’s post over here.

 

We’re closing this thread to continue collecting reports in the largest thread. If you’ve attempted the troubleshooting but not reported your info to us, post the following information over here:

 

  • Your Spotify username (if you're comfortable sharing it publicly)
  • Your device
  • Your device's operating system
  • The Spotify version installed
Comments
fathijs
Newbie

For me the same, it's happening for a week now. Cannot play music on Spotify. 

 

Windows 10

Spotify Premium

Version: 1.0.18.60

 

Tried to reinstall Spotify but no result. 

 

 

 

Fxxk
Newbie

Same problem here!!!

Windows 7
Spotify Premium
Version: 1.0.18.60

Reinstalled, but still not working.. 
It's really pissing me off.

darrel18
Newbie

Same issue here.

Just joined Premium

Win 7, all local files turned off.

 

keep getting this error after almost every song.

 

I tried turning off high quality, same issue. 

Interestingly, when I turned it off, the next song in the queue started to play for 2 seconds, then went silent. You could still see the player time bar moving like the song was playing but no sound. 

 

If I click skip to next song, it start working.

 

This is really sad - *playing* music is the most basic functionality. 

 

This is a show stopper as I listen do music on the desktop at work.

If I don't see/find a resolution to this soon I will try out a different service.

 

 

JPer
Newbie

Similar issue here. "Can't play the current track." on every track I try to play. I've tried albums, playlists and radio, and I cannot get a single track to play. The issue started today; yesterday everything worked well.

 

Uninstalling Spotify + deleting AppData + installing Spotify again did not help.

 

Spotify Premium, version 1.0.18.60

Windows 7

opeknel
Newbie

Same issue for 2 weeks now... I have done a clean install of windows7 for some reasons but no changes.

 

Going back to Dzr for now.

 

Spotify Premium, version 1.0.18.60

Windows 7

113259671
Newbie

I had same problem at work after taking a few days of.

 

After trying all online solutions, like disbling HQ streaming, deleting cache, reinstall, it turned out my collegues had rearranged my audiocable setup, so it was no longer put into the computer.

 

 

Solution: Make sure to have your audiocable inserted into your computer 🙂

jerrynthewriter
Casual Listener

I am a PREMIUM subscriber running1.0.18.60 on a Mac running OS X Yosemite (10.10.5).  I am getting the "can't play current track on every single song in every single playlists.  Briefly, I can play NO music via Spotify on my desktop.

Help, please.

12124397275
Newbie

I am a PREMIUM subscriber on a Mac running OS X El Capitan (10.11.1).  I don't get a "can't play current track" error as other users do. The app simply skips the track and plays which ever track is available. This didn't happen before and is becoming VERY annoying. Please help!

fankomahboateng
Newbie

Issue started after I did the most recent update (1.0.18.60). I'm a premium subscriber running Windows 10.  The issue seemed to be resolved after I did a clean reinstall, but it reappeared after I played 2 or 3 songs.

EmpireITt3ch
Newbie

Soooooo any word from Spotify here?

 

All the sudden my Spotify will not play songs and thinks I'm "offline" even as I type this on the forums. My iPhone and laptop both work fine, on the same WiFi network, and I am a Premium subscriver. I'm running 1.0.18.60.g5fe0413d

 

Sucks paying for something you cannot use =/