Announcements

Error message "You can't open application... because PowerPC isn't supported" on OS X El Capitan

Status: Fixed

Hey Folks,

 

The desktop app asked me to upgrade. I did, it now won't run.

 

I get a message saying "...PowerPC applications are no longer supported."

 

Please fix.

 

2013 27" iMac Core i7 10.11.1

Broken Spotify.png

Hey everyone 🙂

 

We've done everything we can do on our end of this issue, just be sure you have the latest version of OSX on your device.

 

All the best,

Comments
Steph_B
Status changed to: Fixed

Hey there!

Our team's currently looking into this at the moment.

We'd recommend downloading the app here. It'd be best to fully uninstall the app before downloading this.

Let us know if it helps. 

jaydekay

Hi Steph_B,

 

Thanks for your reply.

 

I've completey uinstalled, removed, cleared library folders/files, and used the download link you provided. 

 

The same issue persists, and the same error message is shown once I try to open the newly installed program.

 

Adam_B

Hey @jaydekay,

 

I've just edited the issue title so more people can find it.

 

We've let the tech folks know about this. They're currently looking into a way to fix it.

 

Thanks!

charliegregory

Same issues here. Deleted and reinstalled to no avail. 

charliegregory

Any news on the fix for this?

 

Thanks

denisethelady

Me too.

Please hurry up and fix it!

How can I go back to the previous version?

Thanks.

Steph_B

Hey guys!

 

Thanks for your patience. Our team's still looking into this as we speak.

 

In the meantime, we'd recommend checking to see if you have any OSX updates available, and downloading the app here.

mavelar

Something to add here, app works when open from desktop, but still not working when try to open from Applications folder.

jaydekay

Hey Team Spotify, 

 

Is this fixed yet? The app keeps asking me to upgrade (paid account), but I'm not sure if it will cause further issues. As a work around for the last couple months, I've been running it from my desktop. 

 

Please keep us posted.

slimpicker

Any progress with this issue? I upgraded my OS several weeks ago and Spotify was working fine until tonight I get this strange error. I've tried removing it completely and re-installing, and I keep getting the same error message.

 

Please help!