Announcements

Frequently Disconnects with Chromecast

Status: Closed

I'm a longtime Spotify and Chromecast user and have had no problems (for months...)

 

Now I have a big problem: when casting from my phone and in the middle of playing, Spotify will disconnect from my chromecast (and stop playing).

 

The TV display shows the album cover with music paused. The phone displays the same, but at the bottom it says 'devices available' (meaning it's no longer connected) and will show my cc (chromecast) device. [not finding the device is another intermittent problem]

 

However, it will not reconnect. If I reselect my cc device, it says 'connecting' or a short while and acts like it is connecting - but then abruptly stops and just says 'devices available' again. I can try this repeatedly, but get the same result...

 

I can close and relaunch Spotify, still no luck. Rebooting my phone sometimes works, but not always.

 

Pandory, Napster (Rhapsody), Netflix, YouTube, etc., all work fine - this only happens with Spotify. 

 

 

Here're some of my details:

  • Samsung S6 
  • Android 7.0
  • Spotify 8.4.5.1092
  • Chromecast 1.24.8807 (Chromecast 2nd gen)

 

I've tried uninstall/reinstall, cleared cache, and factory resets, etc. 

 

I have excellent wi-fi coverage and very stable internet.

 

Here is one theory: I think it may have something to do with my wi-fi router changing channels. I say this because I had a similar problem with Spotify dropping my cc connection after I had changed internet service providers. It was only after I made the router stick to one channel did the problem start. I have recently installed a mesh network (Google Wi-Fi) which might change channels. That cannot be altered.

 

Still, I am not having these disconnect problems with any other apps - help appreciated!

Hey @mwstephensandah!

 

We'll be closing this one up, since we haven't heard from you in a while.

 

If you need us again, don't hesitate to open a new thread.

 

All the best.

Comments
Chris

Hi @mwstephensandah,

 

Thanks for reaching out, and welcome to our Community!

 

We're sorry to hear you're having trouble connecting your device to your Chromecast. It looks like a more recent version of Spotify has been released since you reached out. Could you try updating your app to see if that helps?

 

If not, could you try another quick reinstall? This time, could you uninstall the app, restart your device, and the reinstall Spotify from the Play Store? We know it sounds simple, but it's often overlooked. 

 

If you're still having this issue, could you let us know if it's happening to any other devices?

 

Could you also let us know if it's happening to specific songs, or when using a specific feature of the app (eg. Radio, Playlists, Saved Songs, etc.)?

 

Thanks!

mwstephensandah

I've reinstalled Spotify v 8.4.7.1108, which works much better. I was able to play continously for several hours without any issues, followed by another problem-free session later.

 

However, the next day I encountered the problem again - Spotify stopped playing as it dropped the connection to my Chromecast and indicated devices are available. Atempts to reconnect were unsuccessful - so I closed Spotify and switched to Pandora. A couple of hours later, I was able to launch and successfully connect to cc. 

 

So far, I've encountered the disconnect issue only once since updating Spotify.

 

Regarding your other questions:

  • It has not happened with any other device, but that sample size is small. I use my phone more than 99% of the time to cast Spotify. Also note:
    • No problems playing Spotify on my phone with bluetooth connections
    • My phone works fine casting other apps
    • Other decices casting other apps also works fine
  • It does not happen with any specific song
  • The majority of the time, I am playing from a playlist (usually my own, but sometimes a Spotify playlist)
  • Other notes:
    • On at least two occasions, the issue occurred right after I had another app open while Spotify was playing. However, that may have been a coincidence as I was never able to recreate the condition after several tries.
    • Also, I no longer think the issue is related to wi-fi channels changing as I've been able to stay connected for extended periods of time
Chris
Status changed to: Need more info

Hey @mwstephensandah,


Thanks for the info so far!

 

It sounds like the latest update of the app has helped here. You mentioned that the issue come back once so far, could you let us know if it's happened again since? 

 

We'll see what we can suggest.

Alfredo
Status changed to: Closed

Hey @mwstephensandah!

 

We'll be closing this one up, since we haven't heard from you in a while.

 

If you need us again, don't hesitate to open a new thread.

 

All the best.

Env: prod