Help Wizard

Step 1


Galaxy watch - cannot connect to spotify on your phone




Samsung Galaxy 7


My Question or Issue

 Had my watch for about a week now and I was able to connect via remote to my phone and scroll through my playlists and recently played, but today it seems to have a problem connecting.


When I open the app on the watch it says "can not connect to Spotify on your phone. please open the app there to continue". once I tap to the watch I get to the playback setting menu (choosing between remote and stream on wifi) and cant get anywhere else.

My watch is connected via Bluetooth and the app is open on my phone and I still get the message.


Tried disconnecting my watch and phone and reconnecting, turning the watch off and on again, deleting the app from my watch and reinstalling - none of these worked.


Anyone know how to fix this issue?

Hey all,


Issue should be solved now. Keep you apps up to date and try to log in again.


If you can't find the app in the Galaxy Store, be sure to check out this Ongoing Issue.


Have a nice day!


I'm using a Gear S3 with my Samsung S8.  Recently (in the last month maybe?) the remote feature quit functioning on my Gear S3. It just says unable to start spotify.  Sometimes it will launch spotify on my phone and say it anyway.  I've tried launching spotify first and then doing it and still no dice.  I're rebooted both devices, reinstalled the app on both, nothing seems to work. The basic music app on the watch can easily display the current song and all, however I want to be able to switch playlists at work without taking my phone out of my pocket. I work with food so constantly going for my phone is usually a bad idea. I bought the watch with multiple reasons, but full spotify support was one of them.  What can I do? It used to work but it has not been lately. I can use it on wifi but the wifi at my store is absolutely horrible. Any ideas?


I also have premium, not that it matters for this.


I was using an older (lets say unofficial) version of spotify and my remote was working, i then decided to buy premium shortly after getting my gear s3 and update the phone app to the latest official version, and my remote stopped working and i was stumped for days, streaming on wifi worked but choosing remote just said BT disconected, to check my connection even though it was fine. googling people having the same problem and i was SO annoyed with none of their solutions working, then i realized that it was working before on an older version, so i went ahead and looked for an older verision of spotify online, and installed it and my remote on gear s3 worked again with spotify.

TLDR: USE AN OLDER VERSION OF SPOTIFY, I'M USING, if you want you can keep trying different versions until you find the cutoff point where it no longer works and use the newest possible version that works, but i don't even see much of a difference compared to newer versions other than the UI being rearranged. and i mean an older version of the phone app, the latest gear app is fine and isn't the problem

the solution to your problem is literally in your second sentence. "Recently (in the last month maybe?) the remote feature quit functioning on my Gear S3." if you think about it like i did, "RECENTLY", what could've changed between the time it worked and now that it doesn't? an app update!!! so downgrade the phone app to whatever version you had a month or 2 ago and it will probably be fine, (i assume you know how google, find and install apk files) i went as far as a 2016 version but it was probably unnecessary but eh, i don't see a difference from the newest one anyway.



Well the watch also had a Tizen update. Was unsure if it was Spotify at fault 


I am on latest tizen, s7 edge nougat, latest gear s3 spotify app, and spotify phone app, and it worked for me after downgrading from the latest google play spotify app, where as before, i had the exact same problem you mentioned. like i literally found the solution to my problem 30 mins ago and wanted to help out someone with the same problem that posted recently without opening my own thread. 
idk if it'll work for you, but it's something you can try, a solution not mentioned elsewhere as far as i know, i looked everywhere in the last 4 days.


someone keeps removing my latest comment, but whatever, this comment is irrelevant now i guess anyway.


Yea I'll give it a try. I think on the previous Spotify it would work 2/3rds the time too.



Life Saver dude. It's been borked for a bit now. That version 5.5.xxxxx worked instantly gonna go up the revisions and see in what version it breaks. Hopefully I can get it slightly more updated that what it is at right now 😛


Tried it. Watch demands I update to the latest. So I guess I'm stuck for now.



Did you try maybe version 7.0.0? or the, cause maybe that one is too old to be compatible with your s8.


 tried a 5.5 actually. Might give something more recent a go tomorrow.