Help Wizard

Step 1


Galaxy watch - cannot connect to spotify on your phone




Samsung Galaxy 7


My Question or Issue

 Had my watch for about a week now and I was able to connect via remote to my phone and scroll through my playlists and recently played, but today it seems to have a problem connecting.


When I open the app on the watch it says "can not connect to Spotify on your phone. please open the app there to continue". once I tap to the watch I get to the playback setting menu (choosing between remote and stream on wifi) and cant get anywhere else.

My watch is connected via Bluetooth and the app is open on my phone and I still get the message.


Tried disconnecting my watch and phone and reconnecting, turning the watch off and on again, deleting the app from my watch and reinstalling - none of these worked.


Anyone know how to fix this issue?

Hey all,


Issue should be solved now. Keep you apps up to date and try to log in again.


If you can't find the app in the Galaxy Store, be sure to check out this Ongoing Issue.


Have a nice day!


Deinstall the Spotify app in de Playstore and search on Google for Spotify APK.


Hello everyone, 


I just started a chat with spotify support, the issue is clearly in the spotify phone app. 


There is no way to downgrade, unless you download from a suspicious third party, there are no official links from spotify to download a previous version! So we have to wait for now


They have opened an ticket to see what is causing the issue, I'll let everyone know once if I hear anything from my side. 


Don't waste your time on restarting or starting the app. The samsung side works, for now its a software bug. 


Hold on to your samsung watches and your spotify subscription, don't sell them on ebay yet! 


Thank you! And I agree with you, downgrade isn't an option for me either. This bug annoyed me so much because I thought it was the watch's fault. I even reset that thing. Now I just hope the next update fixes it.


Hey guys, I have the same problem with my Galaxy S6 running Android 7.0 and the Galaxy Watch. I have talked to spotify a lot, send them all the information I have, screenshots, everything they asked for. I was patient, the mobile app got 2 updates 1 day after my email with their dev team but still the Remote mode is not working. I am using the Samsung Music app on my watch to control the playback but I want to be able to browse my songs without having to pick up my phone. Anyone have an idea how we bring this up to the dev team so they can finally fix it?


Everything was cool but Google play decided to update when I had updates off. Very annoying.



What do you guys mean downgrade isn't an option?  Are you guys that afraid of a phone app? With one Google search for "Spotify old versions" I got a perfectly working archive website with all previous Spotify versions. Just uninstall the current one and download from there. Only thing you will need to change are settings and downloaded songs.


Who else had this problem? (read below for the solution)


I recently bought my new Samsung Galaxy Gear Watch.

To be honest the Spotify App has never worked flawlessly even on my previous Galaxy S2 but now it won’t connect to the app via Bluetooth for remote control use.

When I first downloaded it, it worked, not 100% of the time, but most of the time. Now it says it can’t connect to the app via Bluetooth. Although, strangely, it opens the app on my phone when I open it on the watch.

I’ve tried the forums and everything they have suggested.

  1. Uninstalling both apps on Phone and Watch (several times)
  2. Logging out of all devices (via my account on the Spotify webpage)
  3. Totally restarting my Watch and connecting to my phone as a new watch
  4. Disconnecting Bluetooth and Reconnecting (several times)

All other apps on from my watch connect via Bluetooth fine and my phone has the latest Android and Spotify update and have a Samsung Galaxy S9+

I have Spotify Premium. I can also play music through my watch’s speaker using the Spotify watch App via streaming

It’s really frustrating, as I’m a dance teacher and use the remote control functionality a lot.

Looking on the Internet, it seems to be a problem, I really hope you can help.

Thank you


Well, Spotify, with the help of some other users, my remote now works fine. Seems your new update is the problem! Grrrr 😞
I uninstalled Spotify from my phone and rolled mine back to the older version (

You'll have to allow downloads from unknown sources first on your phone. Google this, it's easy to find
Here's the link to download to on your phone -

Disable auto update on your Spotify App via the Playstore. After installing the APK. Hey presto, remote works!! 🙂

And SPOTIFY! Next update, in the update information, please comment in big letters that you have solved this. Until then I won't be updating.

Hope it helps 😉



I also had to downgrade to the version me toned in this thread. Was having the same issue as the op.  Really hope they fix this soon, so I can allow my app to update again. 




Having the same issue, and am running version and it is working fine after the downgrades version was installed


Same issue but with a Gear S3 watch, and the same solution also worked for me. However, I don't consider running an old version of the Spotify app to be a long-term solution. Spotify needs to fix this. And the state of their Samsung Gear app is pretty sorry - tons of bugs, and no updates in over a year.