Gear S3 - Tizen 3.0 - No way to permanently stop playback

In its current state, Spotify on Gear S3 after the Tizen 3.0 update is unusable: You can listen to and play music but when you close the app (using the "recent apps" button to close the application).  If you are done listening to music, and decide to make a phone call, use S. Voice or anything that requires the speaker, spotify will start to autoplay after the call is over.  This can literally be 6 hours after you have closed spotify.  

 

Example scenario: I went for a run yesterday morning.  Around 4 hours later I made a phone call using my watch.  After the call hung up, spotify started blaring the song out of my watch speaker while at work.  The *only* way to stop the playback is to uninstall the app.  There needs to be a way of stopping (not just pausing) music so it does not autoplay *every* time you use the watch speaker for anything.

Hey folks,

 

We just wanted to let you know that the right folks are aware of this, and taking a look.

 

Right now, we're not able to provide an exact timeline for a fix, but we'd recommend always keeping your Spotify app up-to-date to ensure you're on the latest and best version.

We'll continue to keep you posted here with any updates.

Many thanks for your patience, and understanding.
/M

Comments
Spotify
Spotify
Status changed to: Need more info

Hey @jamieb122

 

That's very odd. Could you let us know the exact Spotify version you're running? Does it happen on different Internet connections? Let us know if restarting the Gear S3 makes any difference.

 

Keep us posted :)

jamieb122
Casual Listener

@William_13 

Thanks for the reply, I am using the 1.1.39 version of spotify on the gear.  I am in streaming from WiFi in offline, so there is no internet connection (using it for untethered runs).  Here is what I did for replication purposes.  Put Gear S3 in Stream from WiFi, navigtate to playlist and click the download button.  After songs have been downloaded locally, switch into offline mode in settings.  Go play playlist (using Shuffle Now button in playlist).  Background the app, to use running application (background seems inconsequential since this issue also occurs when using no running app).  Complete run, and switch back to spotify.  Hit "Pause" button to stop playback.  Click the bottom button to view the app drawer.  Click the "Recent Apps" button, and then close all.  Use S .Voice to do anything (ask what time it is as a test), as soon as S. Voice closes, spotify begins to play again.

 

Interestingly enough, if you never pause spotify and close the app using the "Recent Apps" method above, spotify never quits playing.  I would expect the behavior would be to stop playing when the app is closed, these two bugs *could* be related but arent neccessarily.

 

Let me know if I can do anything else to help troubleshoot.  Restarting, uninstalling/reinstalling Spotify, and a factory reset on the Gear S3 produced the same results.

 

Alfredo
Roadie

Hey @jamieb122!

 

Thanks for all the info.

 

By any chance, do you have a different Spotify account you could use to see if the same issue happens?

 

Let us know.

jamieb122
Casual Listener

@Alfredo I do not have access to another spotify account unfortunately

iangtimms
Newbie

Hi with my Samsung S8 plus I have a Samsung Gear S3 Frontier watch. Since updating watch to Tizen version 3.0. Every time I take and end a call via the watch - the watch Spotify app starts playing ?!  Please advise. Many thanks. 

SergioDavid
Roadie
Status changed to: Need more info

No worries @jamieb122.

 

Try logging in with a friend's account and let us know if the issue persists. If you're not able to get a friend's login info, reach out to us via Twitter or Facebook. They'll be able to take a closer look at your account to see what's going on.

 

Let us know how it goes.

lutkenhaus
Newbie

same problem, it also starts after i used s voice or the voice feedback from mapmyrun is heard

SergioDavid
Roadie
Status changed to: Need more info

Hey @iangtimms and @lutkenhaus, welcome to the Community!

 

Did this only start happening after updating your OS? Just to be sure, the music keeps playing when you take a call and doesn't stop even after hanging up?

 

Are you able to see a setting on your phone or smart watch that disables music while taking a call? It should be under your sound settings. 

 

Lastly, what Spotify version are you guys running?

 

We'll see what we can suggest once we have this info.

nyikesda
Newbie

Hi,

I have the same issue exactly!

After the first start spotify, this bug comes out. The most striking that spotify's music start automatically whenever a sound comes out from speaker (for example during workout instruction), but spotify app is not running...