Help Wizard

Step 1


Google Alarm Clock app stopped working with Spotify

Hey there folks, 


We've received multiple reports of the Google Alarm Clock not working with Spotify after the latest update. The default alarm plays instead - with the message "You are not logged into Spotify".


This is now being investigated.


Hey folks,


Thanks for your patience while we looked into this issue.


We’re happy to say that this should now be fixed for everyone! Just make sure your app is updated to the latest version.


If you're still having trouble, make sure to post a new thread in the relevant help board here.




@dinomight -

Thanks for your suggestions. I've already tried a clean install. Tried logging out/in 2x last night as well. Still get the default alarm.


Also, to the best of my knowledge, there was no particular event that triggered this. I only use this phone as an alarm (my S22 has an annoying habit of shutting down at night) - so I'm not sure if it updated or not (and patch/release notes are extremely elusive it seems).


I'm not sure if my Samsung S22 Ultra has the same issue, but I keep forgetting to set a Spotify alarm on it to test it. I just set one for tomorrow morning so we'll see.


Here is my screenshot from the Pixel 3XL:










Same issue here.


My device info:

Phone: Pixel 5a

Android version: 13

Spotify version:

Google Clock Version: 7.4 (504317960)


Hi I too have been having this issue 


I have a Pixel 3a, use android 12, and Spotify version

Spotify no longer plays when my alarm goes off. Instead a loud beeping sound goes off instead. On screen it says to log into spotify. If I "log in" then set the alarm for like 2 minutes later it works, but not a few hours.

Thanks everyone for the continued feedback and troubleshooting efforts. Just to assist any efforts by the Spotify team to look into this, I'm posting my own screenshot here of what I see from within the Google Clock app when looking to add a Spotify alarm. I can confirm that I experience the same behavior others have mentioned where it is as if the connection goes to sleep and forgets that Spotify is already logged in. Tapping the login button allows me to select a playlist, but it isn't long before the connection breaks again.




The last Spotify update seems to be from the 6th of February, whereas the last update on the Google clock is from the 24th of Jan.


Edit: just checked and I can replicate the issue on an older (January) version of Spotify as well as an older (December) version of the clock, so it's unlikely to be an app update in itself causing the connection to break.


I wonder if there have been server changes to the login/authentication process. 


This could be caused by some other update (Google Play services?) But the timing for the last Spotify update matches this issue reasonably well.


Just roll back the Spotify app on January update. Works for me.


I've been experiencing the same issue as well.

Fairphone 3
Android version 11

Spotify version


Basically same issue. Before it would play Spotify but now it reverts back to the default song because the clock app is unable to open Spotify. But if you snooze 10 minutes it'll work. At times, when you go into the clock app it'll prompt to login to the Spotify app.


Pixel 6


Clock 7.4 (504317960)


Just a quick update to let you all know that this thread has been passed along to the right folks so the issue can be investigated, and we will let you know here when there's any news to share.


In the meantime, if anyone who runs into this problem can please continue to post your reports here, it will be much appreciated!