Google Assistant Play Soundtrack in Wrong Language

Plan

Premium

Country

USA

Device

Pixel 3

Operating System

Android

 

My Question or Issue

I use Google Assistant frequently to play music on Spotify. There are a bunch of very popular soundtracks that try to listen to but it ends up playing a version from another country. It's consistent in the version it chooses but seems to pick different countries. For example when I ask it to play the Frozen 2 soundtrack, it always plays the Netherlands version. When I ask it to play the Coco soundtrack, it always plays the Portuguese version. 

 

I think this is a Google Assistant problem, not a Spotify one but am not sure. Any ideas?

 

 

Hey there folks, 

 

Thank you for sharing your reports with us here in the Community!

 

We've let our tech teams know about this so that they can look into things.

 

If you're asking Google Assistant to play a soundtrack and you're seeing a result in a different language, make sure to first try the following:

  • Rebooting your Google Home device and restarting your phone
  • Un-linking and then re-linking your Spotify account to your Google Assistant
  • Update all affected devices to the latest firmware versions available
  • The country/region in your Google Assistant is set to the right place
  • Retry in a different internet connection and without a VPN

If the issue persists after that, add your +VOTE here and share the following details in a comment:

  • The device you're using Google Assistant from and its OS/firmware version
  • A couple of examples of commands you try and the URI of the result you get
  • Are you abroad when this happens?
  • Does it persist with non-soundtrack commands?
  • Troubleshooting you've tried

We'll be keeping you in the loop here so make sure to keep an eye out for updates by subscribing to this thread.

Comments
tiger1283
Visitor

Same issue for me. Not ideal when the kids keep asking google to play Frozen II and get it in another language. Didn't have an issue when asking Alexa to play it though, so I agree it's a google assistant problem.

laniwang666
Visitor

When command to Alexa has some problem.

aztecninja
Newbie

The Tangled soundtrack plays the French version. This just started last month and seems to be isolated to Disney soundtracks but I haven’t tried many others. 

ebannasch
Visitor
Super annoying. All was fine for 2 years but then out of nowhere... frozen in Spanish, frozen 2 in Italian and Moana in Japanese. Work around is to make a playlist of the English version and google will prioritize it.
Mihail
Moderator
Moderator

Hey folks,

 

Thanks for reaching out and posting in the Community!

 

We know that it's an often overlooked step, but advise you to log out and back in two times in a row in your Spotify app. It's also a good idea to restart your device. These steps are very effective, but often overlooked.

 

If that doesn't solve things, we recommend that you check which languages are added to your Google Assistant. It can help to leave only the language you want to hear the tracks in activated. You can learn how to do this here. Be sure to restart your device after you modify these settings.

 

Hope you find this useful. Keep us posted how you get on.

dgeorge318
Visitor

This is happening to me on two different accounts in our family plan and family connected google home.  I've unlinked spotify from both accounts multiple times and rebooted the device multiple times.  Still happens.  Exact same scenario.  Only happens when using google assistant to play.  No issues if I manually go in and select them within my phone and cast it to the device.

All settings are set to English only.

Elena
Moderator
Moderator

Hey @dgeorge318,

 

Thanks for keeping us in the loop and for trying out some troubleshooting steps.

 

In this case, we'd recommend reaching out to the folks at Google support to report this issue.

 

In the meantime, we suggest you to play these tracks manually using Connect.

 

Let us know how it goes. We'll be on the lookout for your reply.

caspervanheck
Newbie
Same here, and behavior appears to follow certain rules. If I ask for frozen, I get the Spanish version, if my wife asks, she gets French, if my daughter asks, she gets Arabic. All accounts and devices are set to English (with one exception, which is set to English and Dutch), and I've disconnected, logged out, and restarted many, many times. Weird thing is that the new Google mini home in another room does the exact same.
Alex
Moderator
Moderator

Hey there @caspervanheck,

 

Thanks for reaching out about this.


Can you try to create a new free Spotify account and link that one to one of your Google home devices. You can also proceed with factory data reset to refresh everything.  

 

Let us know if you get the same behavior once that is one.

 

Cheers.

caspervanheck
Newbie

@alex

I have a Spotify premium account (we all do through the family plan). I have already reset all google mini homes and re-linked all of them.

I did just create a new free account, reset one of the Google mini homes, and then linked the two, and this one seemed to work fine for a while. Then, it started favoring the French version of Moana.