Google Clock beeping instead of playing songs from Spotify

Plan

Premium

Country

Poland

Device

Lenovo P2

Operating System

Android 7.0

 

My Question or Issue

I recently installed Google Clock and tried to connect it with Spotify. I struggled with it a lot, but finally after multiple times of receiving a message "Couldn't connect to Spotify. Try again later" I got it working by splitting screen between Spotify and Google Clock. However, even though both apps seemed to be working correctly afterwards, the following morning instead of hearing my chosen song, I heard beeping. I was using cellular data at that time. The next day the same story, but this time I was connected to WiFi. It seems that the bug takes place after some longer period of inactivity of the phone. When I was testing the feature scheduling alarms for e.g. the next minute, everything worked perfectly.

Hey there folks,

 

We haven't heard back from you in a while. 

 

This issue should be fixed.

 

If you're still having troubles after reinstalling the apps on your device, let us know. 

 

In that case, we'd recommend leaving a comment with the relevant info (for example, your device and its OS version, the exact versions of the apps) so we can take another look.

 

Thanks!

DamianMolinski
Newbie

Hi everyone,

 

Samsung Galaxy S8, android 8.0, Spotify v. 8.4.70.666, GoogleClock v 5.4(211689233)

 

I think i found cause of this issue, for me it looks like battery restrictions on some phones.

What u need to do it set GoogleClock/Spotify to be unmonitored. 

You can do via app settings>battery>optimize battery settings. if such settings is not available on

your phone just try to find something like this.

 

Related Issues

Comments
Alfredo
Roadie

Hey @Fisl.

 

Could you send us the exact Spotify version you're using? Also, is your Spotify app set to Offline Mode?

 

If the app is set to Offline, it won't play the song you choose when the alarm goes off.

 

Keep us posted.

1231167044
Newbie

Hi, 

I'm having the exact same issue. My Spotify version is 8.4.64.555 armV7.

 

Spotify is set to online, and it works if I test an alarm set to 1 minute in the future. But if I set it for greater than 10 minutes and leave my phone locked, it won't connect.

- Andreas

Fisl
Casual Listener

I'm using 8.4.66.733 armV7 version of Spotify. I updated it today to that version, so I may notice some changes, but I haven't tested it yet. The app is always set to online mode. After having denied Spotify and Google Clock battery optimisation in system settings, the feature is now working with WiFi, but not with cellular data. The strength of the signal of my carrier is maximal.

 

EDIT: It turns out the alarm clock still doesn't work with cellular data after the recent update. I noticed a notification from Spotify that read "Connecting to Clock". But nothing more happened, still beeping.

Spotify
Spotify
Status changed to: Need more info

Hi all,

 

We've seen a couple of users recently reporting that they're having some issues with getting chosen Spotify content to play on their Google Clock alarm. It seems to be beeping instead of playing the track.

 

Could everyone affected by this let us know the following:

 

  • What exact Android device are you using?
  • What version of Spotify are you using?
  • Is Offline Mode enabled on the Spotify app?

 

Could you then: 

 

  • Re-connect your Spotify account and authenticate use via the Clock app
  • Send a screenshot of the Alarm screen with your chosen content

 

Remember to hit +VOTE as well as commenting with all the info above! Once we have enough examples and votes, we'll be able to move this thread to the Ongoing Issues board to be tracked further.

Thanks!

a-cp_70mqwp48
Newbie

Device: Essential phone ph-1

Spotify version : 8.4.66. 733 armv7

Spotify is set to online. I've had the same issue, where long periods of inactivity, the feature no longer works and I get beeping instead.

1231167044
Newbie

Samsung S9+

Android 8.0.0

Spotify version 8.4.66.733 armV7

Offline mode set to off

 

Found a temporary solution to get Spotify to work overnight. In the Google clock app, from the alarm screen, tap on the three dot menu icon, and click screensaver. My guess is that this keeps allows Spotify to run 

nlellba
Newbie

I'm having this exact issue.

I'm on a Samsung Galaxy s8.

Spotify is not in offline mode.

I'm not loosing connectivity since both wifi and cellular are on.

I currently have Spotify version 8.4.67.886

My Android version is 8.0.0

Thanks,

Nick

SergioDavid
Roadie

Hey everyone!

 

I've passed this on to the right team so they can get a closer look. For now, any users new to this thread and experiencing this issue should add the info @Jack asked for in their comments.

 

Also, don't forget to add your Vote if the issue is happening to you.

 

Thanks for your patience.

Spotify
Spotify
Status changed to: Under investigation

Hi all,

 

We're still seeing a couple of users reporting that they're having some issues with getting chosen Spotify content to play on their Google Clock alarm. It seems to be beeping instead of playing the track.

 

Because we now have enough examples and votes, we've moved this thread to the Ongoing Issues board to be tracked further.

 

If you're new to the thread and haven't already, can you let us know the following:

 

  • What exact Android device are you using?
  • What version of Spotify are you using?
  • Is Offline Mode enabled on the Spotify app?

 

Could you then: 

 

  • Re-connect your Spotify account and authenticate use via the Clock app
  • Send a screenshot of the Alarm screen with your chosen content

 We'd also suggest trying the workaround which @1231167044 has contributed... 

"Found a temporary solution to get Spotify to work overnight. In the Google clock app, from the alarm screen, tap on the three dot menu icon, and click screensaver. My guess is that this keeps allows Spotify to run"

 

Remember to hit +VOTE as well as commenting with all the info above!

Thanks!

kenlay12
Newbie

I have the same problem. Every morning my alarm beeps even though the music worked fine when I tested it the night before.

I am using the Samsung Galaxy S8 version 8.0.0. I am using the free version of Spotify and offline is not enabled.