Google Clock beeping instead of playing songs from Spotify

Plan

Premium

Country

Poland

Device

Lenovo P2

Operating System

Android 7.0

 

My Question or Issue

I recently installed Google Clock and tried to connect it with Spotify. I struggled with it a lot, but finally after multiple times of receiving a message "Couldn't connect to Spotify. Try again later" I got it working by splitting screen between Spotify and Google Clock. However, even though both apps seemed to be working correctly afterwards, the following morning instead of hearing my chosen song, I heard beeping. I was using cellular data at that time. The next day the same story, but this time I was connected to WiFi. It seems that the bug takes place after some longer period of inactivity of the phone. When I was testing the feature scheduling alarms for e.g. the next minute, everything worked perfectly.

Hey there folks,

 

We haven't heard back from you in a while. 

 

This issue should be fixed.

 

If you're still having troubles after reinstalling the apps on your device, let us know. 

 

In that case, we'd recommend leaving a comment with the relevant info (for example, your device and its OS version, the exact versions of the apps) so we can take another look.

 

Thanks!

Related Issues

Comments
SebouChu
Newbie

Same problem with OnePlus 5 under OxygenOS 5.1.5 with Spotify app version 8.4.68.911. Premium account and offline disabled (even if playlist available without Internet)

Moderator
Moderator

Hey everyone!

 

We can see that there is a newer version of the app available. In this case, could you confirm if the issue persists after updating to that newer version?

 

If it does, please make sure to try the suggested steps, click +VOTE and leave a comment.

 

We're still looking into this, thanks for your patience!

/K

 

DamianMolinski
Newbie

Hi everyone,

 

Samsung Galaxy S8, android 8.0, Spotify v. 8.4.70.666, GoogleClock v 5.4(211689233)

 

I think i found cause of this issue, for me it looks like battery restrictions on some phones.

What u need to do it set GoogleClock/Spotify to be unmonitored. 

You can do via app settings>battery>optimize battery settings. if such settings is not available on

your phone just try to find something like this.

 

kenlay12
Newbie

Hi,

 

The solution posted by @DamianMolinski completely fixed the problem for me.

 

Thank you so much!

CyberYuggoth
Casual Listener

I have found that Spotify only connects to Clock if Spotify is NOT running. If I used Spotify to fall asleep or even if I listened to music before bed and Spotify running in the background then Clock can't connect.

 

Moto G6

Version 8.4.7.666

meikaelaeinen
Newbie

I have the same problem and I am using Samsung Galaxy S9+ SM-G965F, Android 8.0.0 and Spotify 8.4.70.666 armv7. I

AeroZ
Composer

Same problem here. It seems that the alarm beeps if the phone is in airplane mode but if the selected song is downloaded then it should be able to play that song, no?

 

Device: OnePlus 5T

OS: Oreo 8.1

Spotify: 8.4.72.821

r4ph43l
Newbie

Samsung Galaxy S7 Edge

Android 8.0.0

Spotify 8.4.70.666 armV7

kaseycottman92
Newbie

 

Clock this morning decided to beep today instead of using spotify and now it says "Couldn't to connect to Spotify, please try again later" I changed NOTHING since last night and it actually worked last night. I'm on a Google Pixel XL 2, Verizon is 8.4.70.666 armv7 and offline mode is disabled

 

Jester646
Newbie

If you disable the power saving mode it will fix the issue. It works for me (galaxy note8)