Google Clock beeping instead of playing songs from Spotify






Lenovo P2

Operating System

Android 7.0


My Question or Issue

I recently installed Google Clock and tried to connect it with Spotify. I struggled with it a lot, but finally after multiple times of receiving a message "Couldn't connect to Spotify. Try again later" I got it working by splitting screen between Spotify and Google Clock. However, even though both apps seemed to be working correctly afterwards, the following morning instead of hearing my chosen song, I heard beeping. I was using cellular data at that time. The next day the same story, but this time I was connected to WiFi. It seems that the bug takes place after some longer period of inactivity of the phone. When I was testing the feature scheduling alarms for e.g. the next minute, everything worked perfectly.

Hey there folks,


We haven't heard back from you in a while. 


This issue should be fixed.


If you're still having troubles after reinstalling the apps on your device, let us know. 


In that case, we'd recommend leaving a comment with the relevant info (for example, your device and its OS version, the exact versions of the apps) so we can take another look.



Related Issues



This is actually a big issue since almost everyone need to be offline (airplane mode or just without internet in general) in order to not be disturbed in our sleep. 

When will it be possible ?


Moto Z2 Force

Android Oreo

Premium Spotify

Offline not enabled


Works half the time and beeps half the time. I wouldn't mind the occasional glitch if there was an option to change the beeping to another tone. It's just jarring to wake up to that when you're expecting a song.


Hey folks,


Thanks for your feedback on this.


@Martin366 - Could you provide us with the following:


  • What exact Android device are you using?
  • What version of Spotify are you using?
  • Is Offline Mode enabled on the Spotify app?

@kiwi8fruit - Could you tell us what your exactly Spotify version is (you can find this by going to the three dots (...) menu > Help > About Spotify in the desktop app)


Many thanks!


Spotify version armv7


I will note that since trying one of the suggested fixes, uninstalling and reinstalling Spotify, I haven't had any beeping. However it's only been one day, that may change. 

Spotify Legend

@kiwi8fruit glad to hear!


We'd definitely like to hear if it's still not working at some point, and we're still looking into this.





Completely didn't work at all today. Even though I have full internet signal, just has a 'clock is connecting' notification. And high awful beeping all morning. Connected to WiFi, no change. 


Only after I restarted both apps, did the song alarm actually work. Not something that's convenient when you're not quite awake yet. 


Did I mention how horrid the backup alarm is? 


I hope this helps in the search for a solution. 


I tried changing the setting in the app to not optimize battery use. I have also tried enabling the screen saver to see if that would work too and unfortunately neither have worked for me. The only thing that has consistently worked for me is to NOT have my phone (Galaxy Note 😎 charging for when my alarm is scheduled to go off. The past several nights I have not used my charger and every morning Spotify music goes off as my alarm. I do still switch on the screen saver function before going to sleep. I have not tried it without. 


Hope this helps some of you.  


Running Android 8

Spotify version

Offline mode NOT on

  • What exact Android device are you using? => Samsung's Galaxy A8 SM-A530F
  • What version of Spotify are you using?
  • Is Offline Mode enabled on the Spotify app? Yes

Hey there @thibc4,


Thanks for posting!


Just to confirm, does the beeping occur when the Spotify app is set to Offline?


If so, please keep in mind that the app needs to be online and connected to WiFi or a data connection for a track to play.