Google Clock beeping instead of playing songs from Spotify

Plan

Premium

Country

Poland

Device

Lenovo P2

Operating System

Android 7.0

 

My Question or Issue

I recently installed Google Clock and tried to connect it with Spotify. I struggled with it a lot, but finally after multiple times of receiving a message "Couldn't connect to Spotify. Try again later" I got it working by splitting screen between Spotify and Google Clock. However, even though both apps seemed to be working correctly afterwards, the following morning instead of hearing my chosen song, I heard beeping. I was using cellular data at that time. The next day the same story, but this time I was connected to WiFi. It seems that the bug takes place after some longer period of inactivity of the phone. When I was testing the feature scheduling alarms for e.g. the next minute, everything worked perfectly.

Hey there folks,

 

We haven't heard back from you in a while. 

 

This issue should be fixed.

 

If you're still having troubles after reinstalling the apps on your device, let us know. 

 

In that case, we'd recommend leaving a comment with the relevant info (for example, your device and its OS version, the exact versions of the apps) so we can take another look.

 

Thanks!

Comments
thibc4
Newbie
Hey Katerina,

The beeping occurs when the Spotify app is not set to Offline and my phone
has a Wifi or a data connection (same problem with both cases).
kiwi8fruit
Newbie

Just an update for this, the backup alarm has changed to something much less annoying. I don't mind the format it is in now. 

 

I'm just glad I'm no longer assaulted by high pitched beeping in the mornings. Also it happens much less frequently.

Moderator
Moderator

Hey @kiwi8fruit,

 

Could you let us know how it's behaving now? Any info you could provide would be very helpful. 

 

Thanks!

Vitenuto
Newbie

Hello, I have same issue. I set Spotify as a wake up song, but always my alarm play song it just beep or use default alarm song. 

If I set alarm to only 1 minute further it does work, otherwise it never work.

I using Spotify before going to bed, so probably my app running at background.

If I look on battery optimalization it doesn't have enabled any restriction on Spotify even on Clock app.

My device: Nokia 6.1 (6 2018)

My system: Android 9

Spotify version: 8.4.90.722

 

Thanks for solve this issue.

And one more question - why it need to not be Offline when I want use playlist that I have downloaded? 

lfelipemonte
Newbie

Hi! ImI having exactly the same problem

 

Device: Samsung S5

Spotify version: 8.4.90.722

Offline: No and doesn't work on offline either (tried already)

 

Thanks for any help you can give us

Luke_S64
Newbie

It's been ages since this issue has started, has anything changed?

Moderator
Moderator

Hey everyone,

 

Thank you for the info you've provided so far. We're still looking into this and will get back to you as soon as we have updates. In the meantime, there's a newer Spotify version available. Make sure to have your app up-to-date (preferably reinstall), and let us know if the issue persists.

 

Thanks!

Luke_S64
Newbie

I reset my phone at the weekend and ever since everything seems to be working as it should. I think I saw a post stating this too, so if you're willing to you could try that

alex4108
Newbie

Android 8.0.0 on SM-G955U

Spotify 8.4.92.949

Offline is disabled

 

 Steps to reproduce

Create alarm in google clock

Bind alarm to Spotify object

Observe functional audio preview during selection

Fall asleep

Alarm time, however Sound is a beep instead of Spotify object

 

meikaelaeinen
Newbie

Hi again,

 

This problem went completely away when my Samsung Galaxy S9+ SM-G965F updated from Android 8 to 9 a few weeks ago. When I had Android 8, it failed maybe 70-80% of times, but during Android 9 it hasn't failed a single time.

 

I hope it fixes the problem for others too!