Google Clock beeping instead of playing songs from Spotify

Status: Fixed






Lenovo P2

Operating System

Android 7.0


My Question or Issue

I recently installed Google Clock and tried to connect it with Spotify. I struggled with it a lot, but finally after multiple times of receiving a message "Couldn't connect to Spotify. Try again later" I got it working by splitting screen between Spotify and Google Clock. However, even though both apps seemed to be working correctly afterwards, the following morning instead of hearing my chosen song, I heard beeping. I was using cellular data at that time. The next day the same story, but this time I was connected to WiFi. It seems that the bug takes place after some longer period of inactivity of the phone. When I was testing the feature scheduling alarms for e.g. the next minute, everything worked perfectly.

Hey there folks,


We haven't heard back from you in a while. 


This issue should be fixed.


If you're still having troubles after reinstalling the apps on your device, let us know. 


In that case, we'd recommend leaving a comment with the relevant info (for example, your device and its OS version, the exact versions of the apps) so we can take another look.



Top Answer

Hi everyone,


Samsung Galaxy S8, android 8.0, Spotify v., GoogleClock v 5.4(211689233)


I think i found cause of this issue, for me it looks like battery restrictions on some phones.

What u need to do it set GoogleClock/Spotify to be unmonitored. 

You can do via app settings>battery>optimize battery settings. if such settings is not available on

your phone just try to find something like this.



Hey there @ProximaCentauri - thanks for posting about this here in the Community!


As the original issue reported in this Ongoing Issue was resolved, the best way to get more help is to post in the related Help Board. We'll be happy to take a closer look and lend a hand there!



Env: prod