Help Wizard

Step 1


Google Clock won't play any playlist from Spotify; Error: (message: failed to switch to local device




United Sates


Motorola Droid Turbo 2

Operating System

Android 7.0


My Question or Issue

The issue started this morning. Spotify was in sync with Google Clock (used as my alarm clock every morning). This morning, the alarm clock gave me a beeping tone with a error on the bottom saying "{"message": "failed to switch to local device"}" even though it says both apps are connected and in sync


So far, I've cleared data and re-installed the app both apps, and did a hard restart on my device and the issue is still ongoing. App version


EDIT: Google Clock app version: 6.1.1, Here is my most recent test and the error that is still ongoing today.  I tried Pandora with Google Clock, since it's capable of syncing to these two apps along with Youtube Music app (which I don't have).  The alarm works fine with Pandora. 


Looking for help on other ways to fix this issue.


Many Thanks





Hey everyone,


Thanks for your replies! This should be fixed now.


If you're having troubles after updating to the latest version available, we'd recommend trying a clean reinstall of the Spotify app with these steps.


If none of these help, we'd still like to know. In that case, we'd suggest starting a new thread in the related Help Board and we'll be happy to lend a hand. 


Have a lovely day 🙂







Pixel 2 XL


Android 9


I woke up with the same problem as the person above, also with Google Clock. I may not have heard it had I not already just woke previously. I hope you have a quick fix for this because I can't use Spotify as my alarm until then. 


Having the same issue and it also started very recently (last few days)







Sony Xperia 10 Plus

Operating System

Android 9.0


My Question or Issue
Looks like we are not alone

I got this message this morning too.


Spotify Version


Google clock version




Been having this issue the last couple of days. No sound at all and just vibration. The spotify connect notification remains in the top bar until the app is closed down.


Nearly missed work today so I've had to change my alarm time, hope they can fix this quick 

Status changed to: Need more info

Hey there folks,


Thanks for bringing this to our attention.


If you're seeing this error message when using Spotify and Google Clock, make sure to add your +VOTE


If you've already tried a clean reinstall of both apps and the issue persists, it'd be helpful to let us know the following details (in case you haven't done so already) so we can pass this on to the right folks:

  • Your device and its OS (operating system) version
  • Exact version of the Spotify app
  • Version of the Google Clock app
  • Any screenshots of the error message

We'll be keeping an eye out for your replies 🙂



A clean install for both Spotify and Google Clock apps seems to help. 

I have tested with a new alarm. Let's see what it does in the morning. 


EDIT: I have tested with setting the alarm for later than 1-2 minutes and when Spotify is not opened on the Phone when alarm fires then the same error message is displayed {"message":"Failed to switch to local device."} and some default tone is played for alarm sound.


The Phone is a Xiaomi Mi8 on Android 9

Google clock is 6.1.1

Spotify is



I experience this issue since the last Spotify update happened yesterday. The Google Clock app was not updated recently.




I have the same issues since the beginning of the week. I did a clean reinstall of the watch app and Spotify itself. It only works when I switch from Spotify directly to the watch app. When Spotify is closed or I haven't used it for like 10 mins it does not work. I hope you will fix this problem soon.

PS: phone is a OnePlus6 with the latest software. Spotify and the watch app are the latest too( downloaded today from the app store)


I uninstalled Spotify and uninstalled the updates to Google clock this morning. I then reinstalled Spotify and reupdated the clock.


After testing another alarm the same thing happened again, ever since the latest update.


Device - Pixel 3 XL

Version - 9 (June Patch)

Spotify Ver -

Google Clock - 6.1.1



(EDIT) - For the record whenever my alarm goes off I am getting NO sound from the Spotify song at all. Just vibrations. The stock alarm tones work of course.


I've been running into this since yesterday too on my Motorola G7 Power. Same message as you



Device: Moto g6

Version: 8.0.0


Google Clock: 6.1.1


Same problem here. Two mornings in a row now it has refused to play Spotify. The first time it said I was not logged in despite Spotify being open in the background when I unlocked my phone. Reinstalled everything and it didn't help. Second time I got the "failed to switch to local device" error message. I tried just changing the time of my alarm to a few minutes later and waiting and there was no sounds for half a minute before it started being again without an error message.