Help Wizard

Step 1


Google Clock won't play any playlist from Spotify; Error: (message: failed to switch to local device




United Sates


Motorola Droid Turbo 2

Operating System

Android 7.0


My Question or Issue

The issue started this morning. Spotify was in sync with Google Clock (used as my alarm clock every morning). This morning, the alarm clock gave me a beeping tone with a error on the bottom saying "{"message": "failed to switch to local device"}" even though it says both apps are connected and in sync


So far, I've cleared data and re-installed the app both apps, and did a hard restart on my device and the issue is still ongoing. App version


EDIT: Google Clock app version: 6.1.1, Here is my most recent test and the error that is still ongoing today.  I tried Pandora with Google Clock, since it's capable of syncing to these two apps along with Youtube Music app (which I don't have).  The alarm works fine with Pandora. 


Looking for help on other ways to fix this issue.


Many Thanks





Hey everyone,


Thanks for your replies! This should be fixed now.


If you're having troubles after updating to the latest version available, we'd recommend trying a clean reinstall of the Spotify app with these steps.


If none of these help, we'd still like to know. In that case, we'd suggest starting a new thread in the related Help Board and we'll be happy to lend a hand. 


Have a lovely day 🙂


Been having the same issue here on my Pixel 3. Should we try a Google forum? I get the feeling the Google clock was using a really old API call that the new update phased out. I'm not sure though, any info helps, thanks in advanced! 


Device: Pixel 2
Version: 9
Google Clock: 6.1.1


Same issue. I don't seem to get an error message but the alarm does not play a song or make any sound at all. 

The alarm does play a song if the Spotify app is already open. So the fix for now is to just open the app before going to sleep. 


Same issue here.


Device: Oneplus 7 Pro ( Android 9)

Spotify app version: as well as

Google clock version: 6.1.1 (238466778)


Rolled back to and disabled automatic updates for now. Alarms work fine, will check back tomorrow to see if it’s still good



Device: Moto G5 Plus

Android Version: 8.1.0


Google Clock: 6.1.1


Does anyone here use a microsd card? My issues started appearing after I installed a 64GB microsd card on my phone a few days ago because I was running out of space. I moved some apps like google play music to external storage. I wonder if that is causing any issues. Other than that I am having the same issue where spotify cannot play out of the google alarm and instead I only hear beeping with that annoying error message.


Device: Pixel 3

Version: Android 9


Google Clock: 6.1.1


Same problem here. Two mornings in a row now it has refused to play Spotify. 

Reinstalled everything and it didn't help. I haven't checked if there's an error message because the stock google alarm is so annoying i shut it off without even looking at my phone.


I would think this is more of an issue with the google clock app not operating properly



Plan - Premium

Device - Pixel  (Pixel 1) 

Version - 9 (June Patch) 

Spotify -

Google Clock - 6.1.1


Same error message in Google Clock.


Note: when error first happened, I deleted and reinstalled Spotify only. Following this, the error would still appear IF both apps were closed prior to alarm, and when phone was both locked and unlocked. When leaving Spotify open in the background, the alarm *did* successfully connect to and play a playlist while phone was both locked and unlocked. This stopped working this morning (June 27th) 



Tested again, still works! Not sure what happened this morning, but Google Clock *will* play my Spotify playlists *only* when I leave Spotify open in the background, with no music playing. 


Same as described above, clean and reset didn't help.


Phone: Nokia 7 plus

Android version 9

Clock 6.1.1



Device: Pixel 2 XL
Android Version: 9
Google Clock: 6.1.1(238466778)


I think there is some issue with "connections", maybe  related to "show only local devices" setting


Fresh reinstall of spotify: not working.

Checked "show only local devices": not working

Unchecked It: working


But now whatever I do clock only beeps. No way to hear the playlist preview in Clock application too.


I uninstalled Spotify and uninstalled the updates to Google clock this morning. I then reinstalled Spotify and reupdated the clock.     After testing another alarm the same thing happened again, ever since the latest update.    


Device - samsung s9+

Spotify Ver - 

Google Clock - 6.1.1(238466778)





Have the exact same issue here. Spotify and Clock both up-to-date.

Spotify ver

Clock ver 6.1.1 (238466778)

Android OS: 9


It *might* have started after alarm kicked off while playing music on another device (Google Home). I'm not sure about that one but that may have something to do with the "can't switch to local device" issue, if you want to look into that.