Help Wizard

Step 1


Google assistant not playing personalised playlists






Nest hub, home mini


My Question or Issue

Ever since Spotify wrapped 2021 came out, my nest devices no longer play my personalised playlists via voice commands. I can see the command come up on my next hub (eg hey Google Play my playlist top songs 2017), but it simply ignores it and plays something that sounds similar. People are reporting this issue on the Google community forums too.

Hey there,


Thanks for all the help in resolving this. We're happy to announce that this should now be fixed.


If you still experience this hindrance, make sure you're using the latest version of both the Google and Spotify software and if so, post in the relevant help boards.




Hey @danz207,

Thanks for posting about this in the Community!

This sounds strange and we'd like to investigate it further with your help. Could we ask you about the current Spotify version number and if you have tried some troubleshooting already, so we can avoid repeating unnecessary steps. You say also that this started to happen after you received your Wrapped 2021 experience, but is this situation occurring with all your voice commanding and playlists now, or just with particular ones? 


It's also worthwhile to perform a clean reinstall of the app, as this is more thorough than the normal one and ensures that no cached data will cause interference with the new installation of your app. Let us know if this makes any difference for you.


Keep us posted, we'll be on the lookout for your reply.


Hi Kiril,


I'm unsure of the current Spotify version as this is an issue with the Google nest devices. I assume it's using an API? There have been similar issues from other nest users on the Google forums stating that personalised voice commands stopped working around the time Spotify wrapped 2021 came out.


I have tried removing Spotify as my default music service and re-adding it but that's not worked.


It occurs will all my playlists. It finds similar public playlists, just not my own.


Hey again @danz207,

Thanks for your quick response.

Did you try any troubleshooting steps or doing a clean reinstall of Spotify besides removing and re-adding it as your default music service in Google Home? We still believe it's best to be sure you're rerunning with the latest version of  the app. If you believe this is an issue on Google's side of things, then maybe it's best to report your feedback on their forum as well. If you'd like us to give you some sort of suggestions or troubleshooting ideas about the Spotify app here, then we'd need the info we requested above, so we can be of any further help.

Keep in mind that the voice commands should be said more or less with precision as in: 'OK Google, Play My [Playlist Name] on Spotify", where  we believe the word 'My' is very important. Here on this page in Google's support site, you can also find the voice commands as prescribed by them.

Hope you find this useful. Keep us posted if you have any questions.


I have similar error and it also started recently so I think it was some upgrade that caused this. I have a public playlist I've created and it was possible to search this on spotify (my friends could find it) and also we could play this on my Google Nest. It is a personalized routine that would play the playlist once someone gets home. 3 months ago it worked just fine and now I can no longer search for my playlist, it is visible to me, it is public (I checked) but no one else can find this and Google Nest can't play it. I found a big ammount of people complaining about the same thing all over the internet.


I have the exact same problem. I cannot get any of my playlists to play with a voice command. It just finds some other playlist on spotify with a similar name.  


It's super frustrating to manually cast or have to navigate through the bizarre curated suggestion list spotify provides.

Hi Kiril,

As others have stated, this seems to be a widespread issue. I am using my voice to the Google devices to play music. Whatever app is on the hub is not controlled by me, but by Spotify, and any updates to it would be controlled by Spotify. Same with the nest devices, they are automatically updated by Google. I am using the same commands as I have for years, I'm specifying it to play my playlists, and the device shows that it's heard me correctly, but it plays a generic playlist instead. Even when I use Spotify connect to play my playlists from another device, I find sometimes it'll insert random songs in there. I have the new 'Enhance' playlist feature off as well.

Hey again @danz207,


Hi to @mdbrennan and @Mionesu as well! Thank you for joining and posting more on this topic. 


Basically, as @danz207 correctly assumed earlier, we on our end just provide the API, so it's most likely this behavior to be caused by some configuration peculiarity on the Google Assistant part. We can however pass your feedback on to some folks on our end as well to see if they can do something about, although as far as we're aware, there's not really much to do.


Using the Connect feature from the Spotify app to control the devices directly via your smartphone instead of using voice commands via the G-Assistant will be the only alternative we could offer for the time being.

Hope this helps clarify things. Don't hesitate to give us a shout if there's anything else we can help with.


Hi Kiril, it is not something related to google as I can't find the playlis inside Spotify. My playlist is set as public but if anyone tries to search this by typing its name "Temporada Ninho Verde" spotify returns a message "this content couldn't be found" it happens inside Spotify itself, it is not related to google, however google assistant returns the same error message. It worked for a time and has stopped working. Is there any contact/support/help from Spotify? I couldnt find any place to contact direct support.


Hi all,


After about two weeks, mine has started working as normal. I'll monitor it over the next few days and see if the issue has been resolved.


Hi @Mionesu,

Thank you for your reply.

We tried to search for this public playlist "Temporada Ninho Verde" that you mention in the desktop app and we were able to locate it 🙂 The one we've found has a cover image with a lake and a bench, contains 25 songs and it's duration is around hour and forty minutes. Can you confirm that you still experience this situation? A reason for this could have been a local internet connectivity issue for you, or maybe you've tried to search for it immediately after creation and it was still not being listed, as this takes a little time.


If this issue still persists for you, then please send us some info about your device's: make, model, OS and the Spotify version number. Also a short screen recording of the issue will be very helpful for us to take a deeper look and give you a better advice.

In case you still need to reach out to our Support team, you can do that through any of these channels.


Hope you find this useful. Keep us posted if you have any questions.