Help Wizard

Step 1


Home page not loading in Desktop and web player - Couldn't find that page error

Desktop app for W10.


My homepage is empty. Been like this since last update.

Hey there folks,
We really appreciate all your reports so far!
Our tech teams have looked into this, but weren't able to reproduce it. Since this issue could be caused by individual network setups, we'll mark it as Not Right Now as it's something that will need to be looked into individually or could get resolved by an overall system and/or functionality change.
If you're experiencing this, we'd recommend making sure to try all the steps below as these usually do the trick:
  • Thoroughly reinstall the app with these steps.
  • Check your firewall and antivirus software/apps to make sure Spotify is whitelisted or set as an exception.
  • Remove ALL entries from the Windows hosts file (not just the Spotify ones).
  • Uninstall any ad-blocker apps.
  • Run Windows in Safe Mode with Networking - if the app works with no issues there, we'd suggest adjusting different network settings and uninstalling any software that might be conflicting with Spotify's connectivity.
  • If possible, try connecting your desktop to the internet via a mobile hotspot. Should the app work through it, consult with your router's manufacturer.
  • If you're on a non-personal device or network (student laptop, student network, corporate laptop, corporate network) get in touch with the administrator for more help.
We hope this helps. If you still need a hand, you can start a new topic in the relevant Help board including all the steps you've tried so far and their outcome and we'll take it from there.

This is the same DancouMaryuu. I actually had Spotify reboot my account with a different email to try and resolve the issue. That seemed to work at first, but now the issue is back.


But to answer your question, there was no mention of Spotify in my hosts file, and I only have access to two networks from the same router – one 2.4G and one 5G. The issue occurs on both.


Hey @Dancou-Maryuu


Thanks for getting back to us. 


In case you observe this issue when connecting to a different network and across multiple devices, next thing worth checking is whether it might be account-related. 


To check this, try logging in to a different Spotify account on your device. You can borrow the login details from a friend or relative, or simply create a free test account by following the steps listed here. If it works with another account, follow the steps in this Spotify Answer next. 


Keep us in the loop here. 


I tried logging into a test account and the issue didn't come up. On my old account it was established pretty fast that it was account-related – hence the reset from Spotify support. But the issue kept repeating anyway.


However, I have noticed that the home page does sometimes come up. But I'm not sure which of the following does it:

  1. Waiting a while
  2. Clicking through playlists
  3. Starting a track
  4. Logging out and back in

That said, it does still give me that red "something went wrong" bar even though I can't see anything wrong.


Also, thanks to the reset, I can't access the account I started this inquiry with. Anything I should do regarding that? 'Cause otherwise I won't be able to mark the problem as 'solved.'

Screen Shot 2021-04-14 at 8.57.59 AM.png

Hey folks, 


Thanks for your replies. 


Could you give it a try using another internet connection to see if you notice anything new? 


Also, let us know if you're having this issue when using a different device. 


We'll be on the lookout.


Hello, @Novy!

Thank you for your quick response! I did a clean reinstall as you've recommended, but it seems like it didn't make any change. I deleted all the Spotify-related Cache, Cookies, and other stuff from my browsers too, but it didn't lead to any results. As it's also the same problem with the web player on two of my devices at the same time, I don't think there's some kind of a caching problem with my computer. I've also tried connecting via various ISPs, but it just doesn't work. The Home page was not showing up in Firefox, Safari, and Chromium Edge, but as soon as I log out of my account it suddenly starts working again. In case this could be helpful, I am using Facebook to log in as it seems it's the only working way for me to log in since I've originally joined Spotify using Facebook. I'll try to get my friends to use Spotify on my Mac tomorrow, but I bet it's more of an account problem here. Good thing the mobile apps still work fine 🙂
P.S. I've tried connecting through TunnelBear VPN, pretending to be from the UK. The Home page still doesn't work, so I suppose it can't be a problem on the ISP's side.


Status changed to: Under investigation

Hey folks,


We've received reports of some users getting an error message - Couldn't find that page - when trying to access the Home screen in the desktop app and web player.


We’ve passed your info on to the relevant team, who are currently looking into it.


If you’re experiencing this issue, make sure to click +VOTE and Subscribe to the thread to be notified of any developments.


Thanks! We’ll keep you posted and let you know as soon as we have any updates on this.


Now everything is back to normal! Both the web player and the app are displaying the home page again!


I didn't do anything specific, so I guess the team has found a way to fix everything. Thank you all for helping to solve the issue. It's so awesome to have those daily mixes back! 🎸🎧


It seems that way for me too, but I'm a little hesitant to claim victory on this yet. The issue's vanished temporarily for me before only to come back again.


Thanks, the problem is solved for me, home page is now accessible.


Getting a very similar issue but it includes both search and home both not working in the main windows app, playlists all appear OK and can play tracks.

Also, the web is app not working in browser at all while logged in, just a blank page, as soon as I log out everything displays fine.

Switching to another PC with windows 10, everything works ok, it's just this one particular device. 

Have tried all suggestions of folder clearing etc and reinstall, nothing is working so far.