Help Wizard

Step 1


Home page not loading in Desktop and web player - Couldn't find that page error

Desktop app for W10.


My homepage is empty. Been like this since last update.

Hey there folks,
We really appreciate all your reports so far!
Our tech teams have looked into this, but weren't able to reproduce it. Since this issue could be caused by individual network setups, we'll mark it as Not Right Now as it's something that will need to be looked into individually or could get resolved by an overall system and/or functionality change.
If you're experiencing this, we'd recommend making sure to try all the steps below as these usually do the trick:
  • Thoroughly reinstall the app with these steps.
  • Check your firewall and antivirus software/apps to make sure Spotify is whitelisted or set as an exception.
  • Remove ALL entries from the Windows hosts file (not just the Spotify ones).
  • Uninstall any ad-blocker apps.
  • Run Windows in Safe Mode with Networking - if the app works with no issues there, we'd suggest adjusting different network settings and uninstalling any software that might be conflicting with Spotify's connectivity.
  • If possible, try connecting your desktop to the internet via a mobile hotspot. Should the app work through it, consult with your router's manufacturer.
  • If you're on a non-personal device or network (student laptop, student network, corporate laptop, corporate network) get in touch with the administrator for more help.
We hope this helps. If you still need a hand, you can start a new topic in the relevant Help board including all the steps you've tried so far and their outcome and we'll take it from there.

I am also facing this issue. I have tried the solutions in this thread but they haven't seemed to work. My playlists and the search function work, but I cannot access podcasts and my homepage is not loading ("Couldn't find that page"/"Oooops, something went wrong"). I tried clean uninstall and reinstall, different internet connections, etc. I also can't access podcasts on my phone app. Is this just a bug we have to wait to be fixed? Thanks in advance.


Same issue, Premium Account. it seems like an account issue because it's happening to all of my devices, Desktop PC, laptop, iPad, Android phone. How can this be a firewall issue? 










Operating System

MacOS Big Sur 11.5.2


My Issue

Home page and search page both display "Couldn't find that page" and often (although only about 90% of the time) shows the "Oops, something went wrong" red banner. I've uninstalled, reinstalled, done a clean install, and none of it has worked. It works fine on my iPhone, which is connected to the same network right now. 


I'm also unable to load any of the general browsing pages. For instance, if I click on podcasts, I get the same set of errors. 


Update: Literally not 10 minutes after I checked my phone, it has also come up with a similar error. I tapped on a podcast and it's showing "Something went wrong. Have another go? Try again."


I had the same problem. Turns out to be an IPv6 issue. My modem was assigning IPv6 address to my Mac. Setting my Network settings to "Link-local only" fixed it. Or if you can turn off IPv6 on your router/modem, that would probably fix it too.


Screen Shot 2021-09-16 at 12.53.00 PM.png


No podcasts will play, homepage does not load on any devices 2 different cell phones, my PC in the browser and the App. I have did the clean reinstall on all of them to no avail. I even tried a new account and it does the same thing. I can listen to music, but i cannot search, use homepage or listen to podcasts... Please fix this before I cancel my premium account.


Same issues, and can confirm disabling IPv6 on Windows 11 also fixed the issue


I am no longer using the application (app).  The Spotify app opens a default home page.  Not with a page listing the music I have selected as favorites, albums, etc...

The work around is not working.  I am currently using Windows 11 and have painstakingly changed the security settings for Spotify.


I am returning to my Desktop Shortcut.  Which works, for now.