How to stop automatic radio after playlist?

Status: Closed

Spotify started automatically playing radio stations based on playlists I have made after that playlist has ended. I don't want this! Sometimes I just want to listen to a playlist and then move on... I don't need to keep playing music (especially since I often listen to playlists while falling asleep- I don't want music playing all night). It's also starting the playlist radio automatically if I am listening to a playlist while offline, and then connect to wifi. It will stop playing my playlist, and start a radio station instead. Or if I had my playlist paused (if I got out of the car to go inside my house, for example), and then my phone connects to wifi, it will start playing the radio out loud- losing both my place in the playlist and playing music from my phone when I don't want to listen to anything! Is there any way to make this stop?? If it helps, I have Premium, not free.

Comments
Alejandro_C
Status changed to: Closed

Hey @nschall, welcome to the Community!

 

Can you let us know what device/operating system and Spotify version you're currently using?

 

We'll see what we can suggest. 

Alejandar

Hey @nschall!

 

Do you still need help with this? If so, just send us the info requested by @Alejandro_C and we'll see what we can do for you 🙂

 

Keep us posted.

MaryC1

Hey @nschall,

 

It seems we didn't receive a reply from your end. For this reason, we're setting this post as "Closed".

 
Don't hesitate to write us back if you need some extra help.
 
Our best,
MaryC1
Status changed to: Closed
 
1233233299

I also have this problem with a playlist radio starting after the last song on a playlist is played. It is very annoying. I do not want spotify to automatically start playing the playlist radio without me requesting it. If any one knows what the solution was to this problem please post!

Triodes

Same problem here, i was playing an offline playlist at night to fall asleep and when i woke up it was still playing radio. It had used up all my mobile data (i have a small data bundle) so my phone bill was through the roof. I want this gone.

Triodes

Oh stupid me, they actually made a setting for this so you can disable it. Just take a look at the settings menu.

indielover93

Go to settings, and scroll down to "AutoPlay" and turn it off. That should do the trick 🙂

Tammymi

Thank you for that it was driving me mad! From an iPhone it's in settings > playback > auto play at the bottom

I tried clicking on the playback button but I can't click on. It doesn't work. I tried quitting out of Spotify, deleting it and redownloading the app. I have the latest update that came out on Jan. 30 2017. 

 

The Playback, Social, and Streaming Quality buttons all do not work.