Announcements

[Indonesia] Errors On Android App

Status: Fixed

Hey everyone,

 

We're receiving reports from users in Indonesia that they're getting either a black screen or a "no internet connection" error on their Android Spotify apps.

 

If you’re experiencing this issue, make sure to add your +VOTE and follow the instructions in the Status Update below.

 

We'll be keeping everyone up to speed here, so make sure to subscribe to this thread!

Hey folks,

 

Thanks for your patience while we looked into this issue.

 

We’re happy to say that this should now be fixed for everyone! Just make sure your app is updated to the latest version.

 

If you're still having trouble, make sure to post a new thread in the relevant help board here.

 

Thanks!

Comments
Mihail
Status changed to: Under investigation

Hey folks,

 

Thanks for reporting this issue to us.

 

We’ve passed your info on to the relevant team, who are currently looking into it.

 

If you’re experiencing this issue, make sure to first give the following steps a go:

  • Perform a clean reinstall
  • Use another internet connection
  • Check if issue persists on another device 

If that doesn't fix thing, make sure to click +VOTE and Subscribe to the thread to be notified of any developments.

Could you also make sure to provide us with the following info, if you haven’t already:

Thanks! We’ll keep you posted and let you know as soon as we have any updates on this.

Alex

Hey folks,

 

For anyone still experiencing this, could you please provide the info requested above.

 

This will help the investigation of this issue 🙂

 

Thanks!

nikoxio

Hello.

 

I'm not sure if this was a region-specific problem, but I'm having a somewhat similar problem in Finland. 

The device is a Sony L4 (XQ-AD52) running on the latest patch of Android 9; build 57 0 A 2 280

Spotify version is 8 6 40 929

 

My understanding of the issue;

The problem occurs when moving out of your Wi-Fi range and onto a cellular connection, (ie. from indoors to outdoors) with the music paused the app. This will make the app lose its internet connection, and not connect to cellular. However, returning to the Wi-Fi range will not re-establish the internet connection, and you have to close the app once, or twice for it to connect back again.

The same goes when trying to re-connect the app to cellular, a restart of the app is required. But it appears that if I turn off the phone's Wi-Fi before leaving the network, the problem does not occur.

While the error is occurring, the app is either completely blank or void of any track pictures with the last played track on the bottom(which will not play a second more) and the notification "no internet connection" above it.

 

I have yet to make a clean install as I didn't think of this as a troubleshooting step, but I'll try this tomorrow in my work environment where the issue presents itself.

 

Screenshots: Google photos album 

 

Slight issues postings this, I got an error "Your post has been changed because invalid HTML was found in the message body. The invalid HTML has been removed. Please review the message and submit the message when you are satisfied.". But it doesn't post, I just get the error again, so I deleted the link feature on it.

This error was then followed by

"Correct the highlighted errors and try again.

Post flooding detected (user tried to post more than 2 messages within 300 seconds)"


Really annoying.

Update: I replaced the dots and 1 slash with spaces on the link.

Update2: I deleted the link to my google drive folder with the photos.

Update3: This error again: "Correct the highlighted errors and try again.

Post flooding detected (user tried to post more than 2 messages within 300 seconds)"
Update4: I will delete the dots from android version number in case it detects them as links, and add the actual link back.

Update5: Invalid HTML error again, retry with no further edits.

Update6: Same error again, will delete the folder link completely.

Update7: Post flooding error again.

 

Sorry if I butchered the explanation.

Sincerely Niko.

 

nikoxio

Update the issue still persists but seems intermittent.

Jeremy
Status changed to: Fixed

Hey folks,

 

Thanks for your patience while we looked into this issue.

 

We’re happy to say that this should now be fixed for everyone! Just make sure your app is updated to the latest version.

 

If you're still having trouble, make sure to post a new thread in the relevant help board here.

 

Thanks!