Announcements

Kenwood Bluetooth Spotify App not connecting to Phone

Greetings Spotifyers,

I use a new Kenwood Headunit which besides Android Auto also has the ability to use the Build In Spotify App to use via Bluetooth.

 

My Phone is the Samsung Note 8 and everything is Up to Date, also the Headunit.

 

The Phone connects via Bluetooth to the Headunit and provides me using the Headunit to take Calls and using Bluetooth Media to Stream the Audio on my Phone.

 

But when I want to use the Spotify App on the Headunit, the Spotify App shows "no connection". When I watch the Option Sliders/Switch for Bluetooth Connections (Calls, Media, etc) on my Phone, I cant turn on the Media Option. But when going back on the Headunit to Bluetooth Media, the Media Option on my Phone goes on. Switching back to the Spotify App on the Headunit, and its Off again.

 

I tried everything from clearing the Cache for Spotify on my Phone to restarting everything. I also disconnected the Phone a few times and also deleted my Phone on the Headunit and the Headunit on my Phone. I also gave it a few times, to maybe load things. I also conected it via Cable and started Spotify on my Phone to maybe load things.

 

Nothing helps.

 

This Problem is only when trying to use the Spotify App on the Headunit via Bluetooth. Android Auto and Spotify works great.

 

Hopefully someone can help me out.

 

Greetings from Germany.

Hey folks,

We've noticed a few people are still having this issue. We've now flagged this with the right team, who are goin to look into it.

 

We're not able to provide an exact timeline for a fix at the moment, but we'd recommend keeping your Spotify app up-to-date to ensure you're on the latest version.

 

Thanks!

Comments
Moderator
Moderator

Hey folks,

 

Thanks for providing us with that info.

 

We have been told that this should now be fixed for you.

 

Would you mind performing a clean reinstall of the app to see if that fixes things for you?

 

We'll be here in case you need any further help.

Newbie

Today I uninstalled the Spotify app and reinstalled it. I still have the same issue that I can not browse my Spotify content from my radio. I installed another company’s music app and that one works fine. I really wish Spotify would work again for me. I really think it has to do with the way it does not go to the same screen it used to on my phone. I used  to just get the Spotify log screen know I don’t.

 

Moderator
Moderator

Hey @MykeJ.

 

Thanks for letting us know.

 

Could you send us a screen recording to show us what's happening on your end?

 

Once we have this, we'll be able to look into this further.

 

Thanks! We'll be looking out for your reply.

Newbie

The clean install did not work with my Pixel 3. 

 

The issue I'm having is described perfectly here: 

Native spotify source in Kenwood DMX7705S - "Disconnected"

 

I did however install an older APK and it works again.

Spotify - Music and Podcasts 8.4.78.530

I have not tried any versions in between the new one and this one, so I don't know at what point it stopped.

 

Newbie

Confirming iOS version of Spotify 8.94.812 has fixed the issue where you cannot browse songs or playlists via Spotify app on kenwood ddx918ws.  Previously would play current song but when browsing it would spin forever on the Spotify stations screen.  iOS 12.1.4

Moderator
Moderator
Status changed to: Fixed

Hey folks,

 

Thanks for your patience while we looked into this.

 

This issue should now be fixed with the latest updates.

 

Let us know if you're still experiencing this issue after updating - we'll look into it.

 

Thanks!

Moderator
Moderator

Hey folks,

 

Just to let you know that this should now be fixed!

 

Make sure to head over to the relevant thread here and leave a comment if you're still experiencing this issue.

 

Thanks! 

Casual Listener

Unfortunately, no, this did not solve the problem I initially reported here. I checked the spotify on my phone, it updated in the night last night. Version on the phone is now 8.4.94.817.

 

Tried connecting to this headset this morning and same problem - BT audio & pandora work fine, spotify "force disables" the BT audio on the phone and says "disconnected" on the headset.

 

Any ideas?

 

 

Newbie

Nice try guys,

 

Its getting close, but still have experienced "Disconnected" a few times over the past couple of days on a Kenwood DNX-994s using the spotify app to a Galaxy s9 (android 9.0) connected via bluetooth.  Spotify is playing, but "Disconnected" is displayed and I cannot skip forward or backward in a playlist. 

 

This just happened and to troubleshoot I powered off the car stereo (driving, so I cannot access phone), then powered back on.  The music started playing again with "Disconnected" displayed, then around 5 seconds it showed the track playing and I was able to control things again.

 

Spotify version 8.4.94.817.

 

Guys, we are PAYING YOU to be able to do this!  Please advise on a fix that works.  

Newbie

Which android version is the latest update to have fixed the issue? I uninstalled the previous version of Spotify that I was using that worked, then installed the latest version, which according to the Play Store was last updated on Februrary 20th. I am on 8.4.94.817 according to Spotify, but the issue is still present. 

Related Issues