Kenwood Bluetooth Spotify App not connecting to Phone

Greetings Spotifyers,

I use a new Kenwood Headunit which besides Android Auto also has the ability to use the Build In Spotify App to use via Bluetooth.


My Phone is the Samsung Note 8 and everything is Up to Date, also the Headunit.


The Phone connects via Bluetooth to the Headunit and provides me using the Headunit to take Calls and using Bluetooth Media to Stream the Audio on my Phone.


But when I want to use the Spotify App on the Headunit, the Spotify App shows "no connection". When I watch the Option Sliders/Switch for Bluetooth Connections (Calls, Media, etc) on my Phone, I cant turn on the Media Option. But when going back on the Headunit to Bluetooth Media, the Media Option on my Phone goes on. Switching back to the Spotify App on the Headunit, and its Off again.


I tried everything from clearing the Cache for Spotify on my Phone to restarting everything. I also disconnected the Phone a few times and also deleted my Phone on the Headunit and the Headunit on my Phone. I also gave it a few times, to maybe load things. I also conected it via Cable and started Spotify on my Phone to maybe load things.


Nothing helps.


This Problem is only when trying to use the Spotify App on the Headunit via Bluetooth. Android Auto and Spotify works great.


Hopefully someone can help me out.


Greetings from Germany.

Hey folks,

We've noticed a few people are still having this issue. We've now flagged this with the right team, who are goin to look into it.


We're not able to provide an exact timeline for a fix at the moment, but we'd recommend keeping your Spotify app up-to-date to ensure you're on the latest version.



Spotify Legend

Hey @Choncie and @schmidtdarren,


Thanks for letting us know. We're sorry to hear that.


We've passed this on to the right team and we'll let you know when there's any updates on it 🙂


Have a good day!

Casual Listener

Same Problem with Dnx 8170 and Pixel 3. Always disconect


I'm still having issues with the same problem as listed, when I use the spotify app on my head unit it disconnects the "media" from my audio options and when I switch to bluetooth it works again. I installed the latest update and it's still the same.


A new update just came through.


That also has not resolved the issue on the Pixel 3, still showing as disconnected.


Still not fixed for me either, kenwood 7017 dabs and galaxy s10 plus.

This is getting annoying 


I've recently tried using Spotify on my Kenwood head unit for the first time and though I am able to play songs from the Spotify app on my phone (which plays on the car audio system), I see the "Disconnected" message on the head unit itself and I'm unable to see the media details nor able to use any of the options in the source Spotify on the head unit.


Head Unit: Kenwood DDX9018SM

Phone: One Plus 5

Spotify App Version: Tried the latest from the app store and currently using


I've had this problem also on the Kenwood dabs unit. Reading on another forum it gave me an idea. 

Android handles permissions differently these days. Not sure this is a proper solution but for now it works...

Go to you apps in settings

Find Spotify

Grant all permissions.. storage, microphone etc (not sure it needs all but haven't had the time to work out what precisely it does need yet)

You should find it now works... Well mine does anyway. Let me know guys. 



No still not working, spent all day trying to figure out why it will play spotify through bluetooth but not spotify app. 


Note 9

Kenwood 7705S


Spotify - this needs to be fixed before you bill me again this month on the 7th or cancel my account. 

I have enabled all permissions uninstalled, reinstalled still not working.


Permissions are all allowed, phone got another update, updated Spotify now at and still nothing. I would just like to know that someone is strill trying to fix this on Spotify's end. As I mentioned before, if I reinstall an older version it works again. 


I still cant connect either, what older versions are people using?