Announcements

Kenwood Bluetooth Spotify App not connecting to Phone

Greetings Spotifyers,

I use a new Kenwood Headunit which besides Android Auto also has the ability to use the Build In Spotify App to use via Bluetooth.

 

My Phone is the Samsung Note 8 and everything is Up to Date, also the Headunit.

 

The Phone connects via Bluetooth to the Headunit and provides me using the Headunit to take Calls and using Bluetooth Media to Stream the Audio on my Phone.

 

But when I want to use the Spotify App on the Headunit, the Spotify App shows "no connection". When I watch the Option Sliders/Switch for Bluetooth Connections (Calls, Media, etc) on my Phone, I cant turn on the Media Option. But when going back on the Headunit to Bluetooth Media, the Media Option on my Phone goes on. Switching back to the Spotify App on the Headunit, and its Off again.

 

I tried everything from clearing the Cache for Spotify on my Phone to restarting everything. I also disconnected the Phone a few times and also deleted my Phone on the Headunit and the Headunit on my Phone. I also gave it a few times, to maybe load things. I also conected it via Cable and started Spotify on my Phone to maybe load things.

 

Nothing helps.

 

This Problem is only when trying to use the Spotify App on the Headunit via Bluetooth. Android Auto and Spotify works great.

 

Hopefully someone can help me out.

 

Greetings from Germany.

Hey folks,

We've noticed a few people are still having this issue. We've now flagged this with the right team, who are goin to look into it.

 

We're not able to provide an exact timeline for a fix at the moment, but we'd recommend keeping your Spotify app up-to-date to ensure you're on the latest version.

 

Thanks!

Comments
Casual Listener

Plan

Premium

Country

USA

Device

Samsung Galaxy 9

Operating System

Android

 

My Question or Issue

 This Kenwood DMX7705S unit supports Bluetooth as source as well as (theoretically) Spotify & Pandora as native sources.

 

I can select BT as source and spotify plays songs, displays song info on the unit - but there is no album art, and no spotify-specific controls (like, add, playlists, etc).

If I select Spotify as source, it says "Disconnected" over the screen even though BT is still connected. If I press play from the phone on the app then it actually plays spotify with spotify as source on the unit, but it still says 'disconnected', no song info displays, and all controls are greyed out.

If I connect by USB and use android auto, spotify does work within the android auto interface (shows art, song info).

Have tried changing many little settings etc, no joy. I have given spotify all permissions and enabled 'broadcast' option in spotify settings in the app. Have also updated the Kenwood unit to the latest firmware posted on their site.

Long & short of it is, I would like to use the native controls with spotify as source on this unit since that's really why I bought the stupid thing... 😐

I will point out that Pandora as native source works fine (art & song info & native controls all work).... Up your game spotify...

If anyone has any suggestions, please offer 'em up. Losing hope here...

Newbie

Having the same issue.. following.

Newbie

I have exactly the same problem in the UK. The head unit is a Kenwood DMX-7017DABS and I use a Samsung Galaxy S8.

 

Android auto works perfect, as well as Bluetooth audio, but the Spotify app just displays "Disconnected".

 

When I start the head unit, the Spotify logo can be seen to briefly appear in the top left of my phones screen before disappearing.

 

I have removed the Spotify app, reset the head unit to default, tried a Sony Xperia XZ handset, but it will not connect. This function worked perfectly until a few weeks ago!

Casual Listener

The Headunit I use is also the Kenwood DMX7017DABS. Funny...

Newbie

Hello,

 

I have the exact same problem with my Kenwood DMX-7017BTS unit.

I can play through bluetooth or android auto via USB cable just fine.

Instead when I try to play through spotify connect on the unit it just says "disconnect" and only plays music from the phone.

 

I have updated every app and phone, even the unit firmaware to the latest, tried resetting and installing, but nothing works.

 

This happened few weeks ago when I noticed it no longer works. If anyone finds the solution, please let me know.

 

"edit" Forgot to mention that I have nokia 7 plus android phone and also tried Samsung Galaxy xcover4 but it's just the same thing, keeps saying "disconnect"

 

Thanks

 

- Mikko

 

 

Newbie

Hi,

 

I have exactly same issue with my DMX-7017BTS unit. Spotify app in the unit keeps saying "disconnect" even though I can play through bluetooth or android auto via usb just fine.

 

This started few weeks ago, until that it worked fine. Nothing seems to work, even tried other android phones beside my Nokia 7 plus, but same thing. Just "disconnect" showing in the spotify app in the unit.

 

Updated my firmware on the kenwood unit, updated phone apps, resetted everything and installed again, nothing works.

 

If anyone finds a solution, please let me know. Thanks

 

- Mikko

Casual Listener

I just tried it with my Old iPhone 6 Plus and it works, well at least its connecting, but I cant get into my Songlist and Scroll down the Songs I saved. Its just playing from the last added Song.

 

So I guess something is wrong with Spotify on Android, cause I also get a "Spotify stopped working" on my Phone after a few seconds sometimes.

 

Will someone from the Spotify Devs check over this? Because I am not alone with this Problem.

Newbie

Same issue. Worked fine untill about a month ago, then suddenly stopped. Pandora works fine, regular blutooth works fine as well. I even got a new phone, thinking that was the issue. Still not working.

Newbie

Same issue. Dnx8170dabs and s8.

Runs good several weeks ago. 

Location Germany

Newbie

 


Same problem with my DDX595. Worked perfectly with my 2 Android phones until week ago. Nothing helps!! Is any solution for it??

Related Issues