Kenwood Bluetooth Spotify App not connecting to Phone

Greetings Spotifyers,

I use a new Kenwood Headunit which besides Android Auto also has the ability to use the Build In Spotify App to use via Bluetooth.

 

My Phone is the Samsung Note 8 and everything is Up to Date, also the Headunit.

 

The Phone connects via Bluetooth to the Headunit and provides me using the Headunit to take Calls and using Bluetooth Media to Stream the Audio on my Phone.

 

But when I want to use the Spotify App on the Headunit, the Spotify App shows "no connection". When I watch the Option Sliders/Switch for Bluetooth Connections (Calls, Media, etc) on my Phone, I cant turn on the Media Option. But when going back on the Headunit to Bluetooth Media, the Media Option on my Phone goes on. Switching back to the Spotify App on the Headunit, and its Off again.

 

I tried everything from clearing the Cache for Spotify on my Phone to restarting everything. I also disconnected the Phone a few times and also deleted my Phone on the Headunit and the Headunit on my Phone. I also gave it a few times, to maybe load things. I also conected it via Cable and started Spotify on my Phone to maybe load things.

 

Nothing helps.

 

This Problem is only when trying to use the Spotify App on the Headunit via Bluetooth. Android Auto and Spotify works great.

 

Hopefully someone can help me out.

 

Greetings from Germany.

Hey folks,

We've noticed a few people are still having this issue. We've now flagged this with the right team, who are goin to look into it.

 

We're not able to provide an exact timeline for a fix at the moment, but we'd recommend keeping your Spotify app up-to-date to ensure you're on the latest version.

 

Thanks!

Comments
Shocket
Newbie

Still not fixed for me either, kenwood 7017 dabs and galaxy s10 plus.

This is getting annoying 

DevendraBhagwat
Visitor

I've recently tried using Spotify on my Kenwood head unit for the first time and though I am able to play songs from the Spotify app on my phone (which plays on the car audio system), I see the "Disconnected" message on the head unit itself and I'm unable to see the media details nor able to use any of the options in the source Spotify on the head unit.

 

Head Unit: Kenwood DDX9018SM

Phone: One Plus 5

Spotify App Version: Tried the latest from the app store and currently using 8.4.77.779

Tcuk31
Newbie

I've had this problem also on the Kenwood dabs unit. Reading on another forum it gave me an idea. 

Android handles permissions differently these days. Not sure this is a proper solution but for now it works...

Go to you apps in settings

Find Spotify

Grant all permissions.. storage, microphone etc (not sure it needs all but haven't had the time to work out what precisely it does need yet)

You should find it now works... Well mine does anyway. Let me know guys. 

 

that_alex__
Newbie

Permissions are all allowed, phone got another update, updated Spotify now at 8.4.98.892 and still nothing. I would just like to know that someone is strill trying to fix this on Spotify's end. As I mentioned before, if I reinstall an older version it works again. 

Shocket
Newbie

I still cant connect either, what older versions are people using?

Jsormaz
Newbie

Same issue, still happening even though this thread is marked solved. Kenwood DMX7704S, s9+ Android 9.0 Spotify 8.4.98.892.

Been broken for months. Super frustrating. I mostly use Pandora now on account of this issue.

Moderator
Moderator
Status changed to: Not Right Now

Hey folks,

We've noticed a few people are still having this issue. We've now flagged this with the right team, who are goin to look into it.

 

We're not able to provide an exact timeline for a fix at the moment, but we'd recommend keeping your Spotify app up-to-date to ensure you're on the latest version.

 

Thanks!

Mainachtsmann
Newbie

Hi, just checking in with the same problem

- Pocophone F1

- Android 9

- Spotify 8.5.1.735

- Kenwood KMM-BT304 / BT305

 

"connecting" on the display but nothing is happening on my device or the radio.

I hope you will find a solution :)

 

EDIT:

Ok i'll take it back, i got it connected by switching Bluetooth off and on multiple times while the Spotify app is open, now it seems to work just fine 👍🏼

gooselee1
Regular

Still not working with the latest Spotify updates across multiple devices. A Spotify rep in another thread just snarkily told community members that they should just update their devices and contact auto makers if they have problems (despite many of us pointing out that Spotify is the common issue across many devices, vehicles, etc.)

 

The lack of response combined with rude comments and missing ownership are leading me to the only logical solution: Cancelling my Spotify subscription. 

J-Rigity
Casual Listener

Same issue here.  Kenwood DMX7704S and Samsung Galaxy S8.  Spotify version 8.5.7.9999.

 

Please fix!!!