Announcements
We're aware that some podcasts are unplayable right now. Additional info can be found here.

Losing connection to Chromecast

Status: Closed

Since a few days the connection to a Google Chromecast is not usuable anymore. I can connect and play a song but after that the connection is still there but I cannot pause, skip, play another song or change the volume. Disabling battery savings is not helping...

 

Chromecast has latest firmware, Spotify latest version and both are on the same network.

 

Please help!

Hello everyone!

 

We'll be closing this thread since we haven't received any recent updates.

 

If anything else comes up, don't hesitate to open a new one.

 

All the best.

Comments
TheCryoknight

I have a chromecast audio that I use to listen to music in my living room. Today when attempting to listen to music I started to playing from my phone then switched to my living room chromecast where it started playing normally. The issue arose when I tried to skip a song it just wouldn't skip. If I were to continue to try to skip on my phone it will act as if I disconnected from my chromecast and play the next song locally while the chromecast continues to play the same song it was previously playing.

I tried reinstalling Spotify from my android resetting my chromecast a different phone the issue persists.

Cast firmware version: 1.25.90308 Country code: US

Spotify Version(on both androids): 8.4.11.1283 armV7 Android Version(On primary device): 6.0 Android Version(On secondary device): 5.0.1

Let me know what other information would be necessary to help resolve this problem.Thanks.

Hubo
Status changed to: Need more info

Hey @TheCryoknight! Welcome to the Spotify Community!

Thanks for your report. Let's get to the bottom of this. Could you try the steps from this article? Those should help here. Let me know how you get on! 🙂

All the best!

TheCryoknight

From the article:

  • You have the latest firmware installed on your Chromecast device.
  • You’re using the app in a country where Spotify is available.
  • You have the latest version of Spotify installed.

@TheCryoknight wrote:

 

Cast firmware version: 1.25.90308 Country code: US

Spotify Version(on both androids): 8.4.11.1283 armV7 Android Version(On primary device): 6.0 Android Version(On secondary device): 5.0.1


  • Your device is connected to the same WiFi network as your Chromecast. Yes, it is. 

All the article helps with to is the inability to connect to the chromecast, not the ability to control it after casting.

"Once running Spotify Connect can be used to control playback from any device, including desktop." This is what is broken I cannot control the playback after casting.

Aimee_T

Thanks for letting us know!

 

If possible, can you log in to another account and let us know if you have the same issue? It can be a friend's or a family member's account.

 

Also, are you able to connect to another WiFi connection?

 

Let us know how it goes 🙂

Ulfis

Got the same problem with all my devices. Something is really broken. 

Ulfis

Got the same problem on three different devices. Also, when selectring a a chrome cast unit(group) for casting the selected unt reverts back to "this unit" when play is pressed. It has worked flawlessly before but now someting is very broken.

 

I can cast perfectly using other apps from my Android devices. Also, casting spotify from my stationary using the webplayer and Google Chrome works perfectly. Android casting is what seems to be broken.

 

I've restarted phones, pads and chromecasts but nothing helps.(they are all automatically updated from Google Play so they run the latest version)

 

I've also followed the link above but since it has been working it was of no help. It is totally useless now.

Hubo
Status changed to: Need more info

Hey folks! Thanks for your reports!

 

That's not cool! Let's get to the bottom of this. Just to make sure, you've all tried the steps from this article? If not, could you let me know how you get on with those?

 

Thanks, keep me posted! 🙂

cejezed

Somehow it started working again... The connection still is not very stable (adjusting volume for instance is most of the time not possible) but skipping, pause and play are working again. Don't know how, I did not change anything...

The mentioned "troulbeshooting" article is not helpful at all.

Hubo

Hey @cejezed!

 

Alright, I'm not giving up just yet! There are a few more things to try. Could you try to follow the steps from this article? Let me know how you get on! 🙂 Also, @Ulfis, how are you getting on with this?

 

Take care!

Ulfis

There is nothing in the article that applies to my problem.

 

Copying what I wrote in another thread:

Got the same problem on three different devices. Also, when selectring  a chromecast unit(group) for casting, the selected unit reverts back to "this unit" when play is pressed. It has worked flawlessly before but now someting is very broken.

 

I can cast perfectly using other apps from my Android devices. Also, casting spotify from my stationary using the webplayer and Google Chrome works perfectly. Android casting is what seems to be broken.

 

I've restarted phones, pads and chromecasts but nothing helps.(they are all automatically updated from Google Play so they run the latest version)

 

I've also followed the link above but since it has been working it was of no help. It is totally useless now.