[Mac] High CPU

Hi,

 

Running Spotify on Mac it at some point gets to 90-100% CPU. Doesn't happen immediatly but happens every time. Restart doesn't help. Only quit, waiting and coming back after a while. 

 

Premium Plan

Spotfiy: 1.1.6.113.gb388fe17

MacBook Air High Sierra 10.13.6

 

 

Hey folks,

 

Thanks for your patience while we looked into this - this should now be fixed for everyone!

If you're still experiencing issues after a clean reinstall, make sure to create a new thread in the relevant help board here and include all relevant details - we'll help you troubleshoot there.

 

Thanks - stay awesome!

Comments
srihari93
Newbie

Screenshot 2019-11-01 at 10.45.15.pngScreenshot 2019-11-01 at 10.44.58.pngScreenshot 2019-11-01 at 10.41.19.png

 

Hope fully this is the info you are looking for

nokturnalist
Regular

I had this problem recently and a clean re-install fixed it.  I think the trick was corrupt files in the cache folder.  If you haven't already, give this a shot (not just dragging the Spotify application to recycle bin).  

 

https://support.spotify.com/us/article/reinstallation-of-spotify/

 

 

srihari93
Newbie

@nokturnalist Thanks. I am aware of this, read it in a few places, tried it multiple times, doesnt work.

nokturnalist
Regular

@srihari93 - Sorry that didn't help.  That was the trick for me 😞

 

I would proceed with debugging from the MacOS console to see if there is anything strange happening. 

  1. Launch "Monitor" (command + Spacebar -> type in "monitor")
  2. Launch "Console" (command + Spacebar -> type in "console")
  3. Launch Spotify, wait for the CPU to spike in "Monitor."

Give it a minute, then filter only spotify messages like in the screenshot:

 

nokturnalist_0-1573074294522.png

 

You may find something in there that might hint to the issue.  Another tip, keep an eye on the system clock, look for when the CPU spike happens, then look at the timestamp in the console log you just took.  That should tell you what is causing the spike to happen.

tnotnotno
Visitor

looks like my problem solved when I noticed some upgrade of an app had happenned recently, my actual version: 79CC8F12-DD7E-4A84-A4F9-6A5D04EDA11F_4_5005_c.jpeg

Moderator
Moderator
Status changed to: Fixed

Hey folks,

 

Thanks for your patience while we looked into this - this should now be fixed for everyone!

If you're still experiencing issues after a clean reinstall, make sure to create a new thread in the relevant help board here and include all relevant details - we'll help you troubleshoot there.

 

Thanks - stay awesome!

nokturnalist
Regular

Would be interested to know what the cause was if available.

tnotnotno
Visitor

For me it worked seemlesly without clean reinstall! just some overnight upgrade, and that's t. Thanks Peter. Is there any info you can give us on that issue which caused us months and years problems? My solution was to use Chrome, before I found out, I had been seriously thinking of switching to another platform!!! This is probably not what spotify wants? 🙂

srihari93
Newbie

@nokturnalnh I reinstalled Spotify by following the clean reinstall guide again and still have the issue.

Thanks for the console tip. There are a few errors and faults, don't know which one of them is relevant to my issue.

 

@Peter Is there a way to send these console logs to Spotify engineers discreetly? Probably the engineers would also appreciate a direct look rather than taking stabs in the dark.