Announcements

Mac desktop application forces discrete graphic card

Status: Closed

Hi,

 

On my laptop (MacBook Pro mid-2010), Spotify (1.0.42.151.g19de0aa6) always uses the discrete graphic card (both the application itself as well as the helper deamon). Consequently, Spotify drains the battery.

 

After investigating the issue, I found that there were more users experiencing the problem, which was fixed using the following: https://developer.apple.com/library/content/qa/qa1734/_index.html, which Spotify has now adapted (which I found when I looked at Info.plist). However, this problem only fixes the issue for 2011 and later MBPs. Other's suggested it was due to the advertisements shown in Spotify, but I have been using premium for years now, so that is not the issue here.

 

Therefore, I would like to submit this as a new issue (or old issue that has not yet been fixed).

 

 

Thanks,

Joris

Hi guys!

 

We're closing this thread as we haven't heard back from you in a while. Don't hesitate to give us a shout if you still have the same issue.

 

Have a great day 🙂

Comments
Dreadlord
Status changed to: Closed

Hello @hertogjoris,


Welcome to Spotify Community!

I am going to send this to the staff and see what they can suggest.

Meanwhile, can you please let me know what is your operating system?

 

hertogjoris
Dear Dreadlord,

Thank you for your reply. I am currently using MacOS Sierra 10.12.1
(16B2555).
Dreadlord

Hello @hertogjoris,

 

Can you try a clean reinstallation? Check out the steps here.

If the issue persists after that, can you send me a screenshot of your energy settings while running Spotify?

I have a 2015 MBP and the newest version of Spotify still showed that "Spotify Helper" required high performance graphics. A clean reinstall appears to have resolved this for me. Thanks!

Mara_F

Thanks for letting us know @user-removed, we're glad everything's working!

 

 hertogjoris, can you try reinstalling the app? Does that help? 

 

Hope to hear back from you soon. 

RodrigoPalma
Status changed to: Closed

Hi guys!

 

We're closing this thread as we haven't heard back from you in a while. Don't hesitate to give us a shout if you still have the same issue.

 

Have a great day 🙂

balronek

 I am having this issue with MBP 2015. I have checked the plist.info file and the autoswitch features is turned on (as that was supposed to be a solution). Spotify is still using dedicated gpu, which sucks.

 

I tried reinstalling, didn't help. One of the spotify helpers is still requiring the gpu.

salzamt

hey, this is still happening for me. any plans to get this fixed?

salzshot 2018-03-07 at 13.09.49.png

 

salzshot 2018-03-07 at 13.07.01.pngsalzshot 2018-03-07 at 13.10.50.png

Woet

A clean install fixed it for me.

balronek
Lucky you! 🙂