Help Wizard

Step 1


[MacOS] Desktop app crashing, Home page not loading

We've received reports from Mac users that the desktop app crashes and the Home page refuses to load - an error message "Something went wrong" is displayed instead.


This is being investigated.

Hey folks,


Thanks for your patience while our tech team looked into this issue.


We’re happy to announce that this should now be fixed for everyone! If you're still having trouble you can post a new thread in the relevant help board here.



No such folder on my system - did a search too. So while I’m pleased it was a fix for you, it certainly wasn’t for me and I’m still having to play all my Spotify tunes through their website - BORING!

I have solved the problem by replacing the latest version of Spotify with an older version of Spotify.


  1. Look for older versions spotify mac on the web. I used the source: Uptodown.
  2. Scan the downloaded file with an anti-virus.
  3. Remove the current Spotify from your Applications
  4. Install the older version
  5. Done

Running MacBook Pro (Retina, 13-inch, Early 2015)

MacOs Montery 12.3.


Greetz Matt.


Like the other users since 4-Oct-2023, I am a MacOS user (MacBook Pro (Retina, 13-inch, Mid 2014) running MacOS Catalina 10.15.7 (19H1323)), and the problems have persisted. To be specific, the home page, search function or access to any online content does not work on the Desktop App, but I am still able to play songs in any of my playlists, even though they are not 'Downloaded Songs'. However, I am not able to click those songs, artists or albums.


The Spotify Web Player and my iOS App work fine.


I have followed the suggestions of others on this forum, such as deleting the Application Support files and restarting. I have done a clean uninstall and reinstall. I have downloaded previous versions of Spotify from multiple years ago.


Nothing has worked. Can this issue be re-opened, as there are others apart from me clearly still having this issue...


@lloydyoliver try the following tutorial: 


If that also doesn't work, try to completely delete the application according the steps in the tutorial and install a much older version instead. Something from 2020 or much earlier. The one that worked for me was a version from 2020.


I hope this would help you.




@lloydyoliver as @matthewpatty said try with this version, it worked for me downloaded from the dmg file we shared previously. Hope it'll help you.