Massive battery drain

Since last update, even if Spotify is playing in the background, still it drains 30% of battery in one hour (ios 11.4.1). If spotify is on, phone is heating massively.

 

Reinstalled the app, updated ios from 11.4 to 11.4.1 and its still the same.

 

Please update asap, this is disgraceful since I pay premium.

Hey everyone,

 

Thank you for all the info you've provided. We'd like to inform you that all identified optimizations have been deployed. You can still provide additional feedback in this thread and it will be passed on while we continuously work to improve the app.

 

Thanks!

Comments
Jemi
Spotify Legend

@mweems10 and @Limpidlizard51 could you send us a screenshot of date/time stamps of when this happens for example in a battery usage chart?

 

Thanks!

Dhuynher
Newbie

There's battery drain on the Android app too.

  • Device: Pixel 2
  • OS version: Android 9
  • Spotify version: 8.4.70.666

The battery drain has been happening for the last several months. It occurs after using the app and shows up as Google Play Services and Spotify in the battery list. If I don't force close the app after using it, it continues to run in the background and use battery. 

Moderator
Moderator

Hey,

 

Kind reminder that we need the date/time stamps of when this happens. If this is still an issue on your device, send us a screenshot of battery usage chart including the timestamp and date :) 

 

Thanks!

MastarLin
Newbie

6D7BC9BD-83CE-43F0-AB67-A089AE1F1E55.png

 

iOS 12 

iPhone 8 

8.4.71.578

 

Experiencing when streaming music that hasn't been cached.... 

rat_whiskers
Casual Listener

Plan

Premium

Country

USA 

Device

Samsung Galaxy S5

Operating System

Android 6.0.1 Marshmallow

Spotify Android

8.4.70.666

 

I know this thread is dominated by iOS issues, but this seems to be an issue for Android Spotify as well.

 

[REDACTED 10/20/18]

 

After many weeks worth of testing, this doesn't seem to be a Spotify exclusive issue. Tracing it down has been a hair-pulling experience, but it's clearly not related to the iOS issues others are having.

panait_iulian
Newbie

I have this ploblem also, i have a ipod touch 7gen, all of my music its downloaded and i listen in ofline mode, all my background apps are stopped. Sometimes its its works perfectly after 4h of listening over Bluetooth my battery from 98% gone to 95%.. but sometimes happens (more often now) that after 2h of playing my ipod got really hot and all of my battery its gone for no reason i tryed everything uninstall the app donwload the music again nothing changed its really bad. I really love the music on Spotify but its make my change to apple music and also now i have ios 12 and latest Sotify update. Please fix this app its really bad optimazed

Moderator
Moderator

Hey guys,

 

Can you all please confirm:

  • Version of the Spotify iOS app (after reinstalling first)
  • Version of iOS you're running on your device
  • Model of iPhone / iPad you're using

Thank you so much for working with us. We'll be on the lookout for your replies.

panait_iulian
Newbie

So the device its a ipod touch gen 7, ios 12(16A366), Spotify version 8.4.72.740. Recently i uninstall the app and install again download all my music ( i had to keep the screen on all the tine becose i dont know why the music dosent download with the screen off or if im in another app even if the app has permission to refresh in background) and after that i desable everything that i dont need (gapless play, audio normalization, equalizer, feedback sounds, behind the lyrics, stranger things mode, publish activity, waze navigation and some notification) and now its working a lot more batter after 8 hours of playback i got 74% battery left

MastarLin
Newbie

 

Spotify version is 8.4.72.740.

iPhone 8

 iOS 12.0

Currently going to uninstall it and reinstall it to test it out tomorrow! Battery drain is mostly occuring with 3G/LTE. On wifi the battery is better. Also when streaming music that isn't cached the phone gets heated a lot! 

Jemi
Spotify Legend

@panait_iulian great to hear it's working after reinstall! :) 

 

@MastarLin did you try again? How did it go?