Metadata Broken - Subaru 2016-2017 WRX

Metadata shows up for the first track however when skipping through other tracks new metadata does not show up.  

 

iOS

iphone 6s + 

 

Metadata works for tracks that are playing from iTunes

Hey there!

 

We hope you're well.

 

We've now heard back from our best tech folks, who have been looking into things here.

 

As this issue isn't isolated to Spotify, we'd recommend reaching out to the folks at Subaru for some more info on this. This should be the next best step.

 

Do let us know if there's any other questions in the meantime 🙂

We'll be right here.

 

Thanks, and take care

 

/M

 

Comments
Leo
Status changed to: Closed
 
EstefanyA_Bog

Hey @youthsoccer38, thanks for coming to the Community for help!

 

Does the same thing happen on other devices? It'd be also worth reinstalling the app with the steps here: https://support.spotify.com/using_spotify/troubleshooting2/reinstallation-of-spotify/. 

 

Let us know how you get on.

 

thew_ham

I'm having this issue in my Subaru with Starlink too. Two devices running same iOS version and Spotify version. Also tried updating to iOS 10 Beta on iPad and that hasn't resolved it. 

 

Seems there was an old bug around a couple of years ago which exhibited the same or similar behaviour when the iOS music app had no music in it. Have tried that workaround and no joy. 

 

Devices all worked fine previously. Now no album art or track data. And the controls don't work from the car either any more. Super frustrating as I use this every day. 

 

I should also add that I have tried different cables and USB ports in the car system. 

thew_ham

@EstefanyA_Bog Your URL posted above 404's for me FYI. Can you please post correct link?

MaryC1

Hey @thew_ham

 

Sorry about the broken link. Here's how you can reinstall the app on your devices. Let us know how you get on.

 

Just to check, @youthsoccer38, does this happen across all your devices, or it's an isolated issue with your iPhone.

 

Keep us posted.

thew_ham

Right, so it's just delete the app and re-install it then? Not sure why that needs a page to explain! 😉

 

Definitely already re-installed the app (several times now). Nothing has worked so far, so hoping this is a bug in the latest release. There are some old thread on here which seem to indicate this has broken before.

 

Just switched back from Apple Music too - don't want to have to change again! 😞

youthsoccer38

@MaryC1 Hello thanks for the response.  I don't have any other devices to check the spotify app with but when I pair my iphone to other vehicles I have no problem.  I'm not sure if its an issue with Subaru's Starlink or if its an issue with the way the data is streamed from Spotify to the head unit.  In any case however, it seems like if the music is actually on the phone itself (such as on iTunes), it has no problem with metadata.  However when I use pandora, spotify, google music, it doesn't update the metadata.  It only shows the first track and then after that it doesn't update when I skip to another track.  

FabianS_Bogota

Thanks trying it @thew_ham, let us know if you've tried with a different device. Also, let us know if the same happens with other apps like @youthsoccer38 mentioned. We'll see what to suggest. 

 

If possible, try the same while connected to a WiFi network and let us know if it makes any difference.

 

Let us know the Spotify version you're using and if you remember, the last version that was working with Subaru Starlink. 

 

Keep us posted.

thew_ham

Hi @FabianS_Bogota

I've tried using my wife's phone (same versions) and also using different
cables. Nothing works.

Apple Music works fine. I'll download and test some other apps tonight.
Spotify does work via BlueTooth as I mentioned.

I'm using version 5.7.0.1055. I think the earlier version worked, but
cannot be sure if it was an iOS update (9.3.4 or 9.3.5) around the same
time which caused the bug.

Thanks again for your help.

MaryC1

Hey guys!

 

There's a new version of the app right now, so could you resintall once again and check if the issue persists? Also, @thew_ham were you able to test out what @FabianS_Bogota suggested?

 

Keep us posted.