Announcements

Missing dependency on Debian package

Status: Not Right Now

Device:

Linux

 

Operating System Version:

Debian Jessie

 

Spotify Version:

1:1.0.28.89.gf959d4ce-37

 

Description:

spotify-client package is using `xdg-icon-resource` during install, this program comes with `xdg-utils` package but spotify-client doesn't have this package in `Depends` field. Installation kept failed until I installed `xdg-utils` package.

 

To reproduce:

  1. Install minbase variant of Debian Jessie.
  2. Try to install spotify-client from spotfiy repositories.
  3. Installation will fail with:
    Setting up spotify-client (1:1.0.28.89.gf959d4ce-37) ...
    Error: Could not find xdg-icon-resource
    dpkg: error processing package spotify-client (--configure):
     subprocess installed post-installation script returned error exit status 1

Workaround for users:

Install `xdg-utils` package.

Workaround for Spotify developers:

Add `xdg-utils` package into `Depends` field of `spotify-client` package.

Comments
Jason
Status changed to: Not Right Now

Hey @fstx

 

Thanks for reporting this one.

 

Right now, we don't officially support Spotify on Linux devices. Our Tech folks work on the Linux client in their sparetimes though, so we'll forward this information on to our team.

 

Let us know if there's anything else we can help with.

woocash

Thank You for this!

Goodman
Status changed to: Not Right Now
 
Goodman
Status changed to: Not Right Now
 

Env: prod