Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Music cuts out briefly on Echo devices

We've received reports that the music occasionally cuts out when listening to Spotify on Amazon Echo devices. This occurs both when controlling the music directly in the app and with voice commands.

Hey folks,

 

Thanks for reporting this issue to us.

 

We’ve passed your info on to the relevant team, who are currently looking into it.

 

If you’re experiencing this issue, make sure to click +VOTE and Subscribe to the thread to be notified of any developments.

 

Could you also make sure to provide us with the following info, if you haven’t already:

  • your device's make, model and OS version
  • the version of your Spotify app
  • the model of your Alexa device as well as the firmware version
  • the troubleshooting steps you've tried so far

Thanks! We’ll keep you posted and let you know as soon as we have any updates on this.

Comments
Foureyes44

When I play Spotify via my Amazon Echo, the music plays fine, but drops out for a moment every so often. Like it is losing connection for a second or skipping. This is a recent problem and only ever happens while playing via my Echo. I have five of them and it happens on any of them, so it is not specific to one device. Playing anything else on the Echo, like Amazon Music, plays perfectly. It's only Spotify, however if I play Spotify on my Mac, no skipping. It works fine, so it seems to be to do with the way Spotify and Echo are working together. 

 

I've had Spotify for a few years now and never had this problem until just recently. Why is this happening now and how can it be fixed?

 

Plan

Premium

Country

Canada

 

dontwantaprofile

Having the same issue, hope a reply brings more attention

Alex

Hey folks,

 

Thanks for reaching out about this in the Community.

 

Sorry to hear that this issue started happening recently with your Echo devices.

 

In order to get to the bottom of this, we'd need to go through some troubleshooting.


Can you let us know if this is happening only if you play Spotify directly from the Echo via voice commands or also when you start playback from another device and change to the Amazon speaker via Spotify Connect?

 

In the meantime you can check if there are any firmware updates for the speakers and let those run. You can also restart your router and see if that has any effect.

 

Keep us posted.

Foureyes44
It happens when I play using Spotify Connect. I find it easier to use Spotify on my iPhone or Mac to navigate to the playlist I want so don’t use the voice as often, but when I do, it also skips. It happens when I use both my iPhone or Mac.

Echo firmware updates happen automatically, so no update needed.
georgr14

Hi there, 

 

Having the same issues as described above. 

  • Happens on Echo Dot (3rd gen), while playing only from one speaker (have not tested it out when playing on a group of speakers)
  • Spotify Premium account, US West Coast
  • Started about a month ago (January 2022)
  • Cuts out/stutters/lags for about a second at a time, playback resumes automatically after having cut out
  • No consistency noted between time of day or specific playback mode (happens both when starting to play from the Echo Dot, as well as when having started it on the Spotify app and then switching over to the speaker)
  • Confirmed that internet speed test is good, has not dropped or slowed down since before this issue started happening
  • Like a commenter above mentioned, versioning is up-to-date on Echo itself automatically, as well as on the Spotify app (iOS, if that detail helps)

As an additional issue, this also started happening when playing Spotify off of the desktop version *only* when online - this does not happen in the offline mode on the desktop app. This leads me to believe it's an issue with Spotify, rather than an issue with Amazon. And specifically with connection/buffering to Spotify, rather than with any sort of corruption with music files or a global connection lag. 

 

Any help would be appreciated!

Yordan
Status changed to: Need more info

Hey everyone,

 

Thanks for bringing this to our attention.

 

We'd like to investigate further, so if you're experiencing this, please add your +VOTE and provide us with the following info (if you haven't already):

  • your device's make, model and OS version
  • the version of your Spotify app
  • the model of your Alexa device as well as the firmware version
  • the troubleshooting steps you've tried so far

We'll then forward it to our developers so they can look into it.

Thanks!

Foureyes44

I have been communicating also with a support agent via Facebook Messenger and went through numerous troubleshooting, so have tried pretty much everything. Answers to your questions:

 

  • Device is different iPhones, different Mac computers. It's not limited to any specific device. Devices include iPhone X, iPhone 6, iPhone 6S, MacBook Air M1, older 27" iMac. All running latest OS or iOS.
  • The Spotify app is the very latest. It's updated regularly and automatically on Mac and iPhone.
  • The Alexa is also numerous devices.  Six in total including Echo Dot and Echo. All 2nd gen versions. Firmware is automatically updated, so whatever is the latest is installed when it is released. There is no manual update, so it's just the latest.

As above, so many steps have been tried. Restarting all devices and wifi networks. Trying test account. UnLinking and relinking. Reinstalling Spotify. Removing access from Alexa and restating access again. Cleared device cache. If you have any other ideas, let me know.

At the risk of repeating, want to say that no other media played through these devices skip, only Spotify. Does not matter if I request Spotify with voice or using one of my devices to start the playlist or music I want to hear.

Foureyes44

Listening last night, music dropped frequently. Really is disturbing the experience of listening and frustrating that this is a service I am paying for too. Imagine watching Netflix and the picture and sound keeps going black for a moment while watching. It really isn't acceptable and I hope this will be resolved very soon.

 

EDIT: Notice that there are many other posts about this issue, all of them unresolved.  The linked post suggests it is resolved, but in that case, the signal was the issue. In my case signal is very strong on a 1 gb wifi service, so very fast and very near the wifi router too.

 

This is very worrying and makes me wonder if it means that this is actually a permanent problem and if I need to move to another service. 😕

Gravitybored

 

Echo Dot 
Device Software Version 675726720

 


i use the echo dot exclusively as a Spotify connect device attached to my home stereo.  It worked flawlessly until approximately 2 weeks ago.

Foureyes44
Yes, this problem is relatively new for me as well.