No internet connection/ app shows offline despite on WiFi or data


Hi. For the past few days, I've been completely unable to use spotify on mobile data. I have the allowance to do so but all the tracks are grayed out and I get a "no internet connection" error at the bottom. It works perfectly fine on WiFi.


I have tried:

Uninstalling and reinstalling 

Logging out and back in several times



I have the Premium Student plan and a Samsung Note 10.

Hey there folks,
We really appreciate all your reports so far!
Our tech teams have looked into this, but weren't able to reproduce it. Since this issue could be caused by individual network setups, we'll mark it as Not Right Now since it's something that will need to be looked into individually or could get resolved by an overall system and/or functionality change.
If you're experiencing this, we'd recommend making sure to try all the relevant steps first as these usually do the trick:
  • Thoroughly reinstall the app with these steps.
  • Check your firewall and antivirus software/apps to make sure Spotify is whitelisted or set as an exception.
  • Remove ALL entries from the Windows hosts file (not just the Spotify ones).
  • Uninstall any ad-blocker apps.
  • Run Windows in Safe Mode with Networking - if the app works with no issues there, we'd suggest adjusting different network settings and uninstalling any software that might be conflicting with Spotify's connectivity.
  • If possible, try connecting your desktop to the internet via a mobile hotspot. Should the app work through it, consult with your router's manufacturer.
  • If you're on a non-personal device or network (student laptop, student network, corporate laptop, corporate network) get in touch with the administrator for more help.
If you're still having troubles after checking all these, let us know by starting a new thread in the related Help Board and including all the steps you've tried so far and their outcome.
We'll be happy to take a closer look and lend a hand there!

Related Issues


Having the exact same issue on my Galaxy S10e. Super frustrating

Casual Listener

Same problem.  I've tried on a pixel 2 and pixel 3 using both the apk and trying to play through my phone's browser.  The problem appears on both WiFi and Phone data.  Network is working for the phone using WiFi and Phone Data with phone browser, email, other apps on both phones.


Also, I cannot play anything through the browser interface.  Also, using the desktop client (Ubuntu 18), I am getting a message about a firewall problem.  I'm not sure if this is related since I've never used the desktop app before.


Basically, I can't play Spotify on anything.  


I have Premium plan and am in USA.  

Casual Listener
Oh - Some other things I've tried:
1. Logging out
2. Clearing data and cache
3. Uninstalling and reinstalling the latest app onto my phone
In all three cases, once I've logged out, I cannot log back in. Instead I get a message about not being connected to the internet.

So here is a screen shot just so you can actually see it. Full LTE as seen & no connection. 

Casual Listener
This thread is describing the same problem:

This is screen I got. Then I logged out, cleared data, did a complete reinstall, etc. and cannot log back in. "No Internet connection available". Maybe a systematic problem?
Casual Listener

Recently added this private DNS to block ads. This was the issue. Turned it off, and it works now 

Casual Listener

Looks like the problem for me was using Adguard DNS.  If I switch that off, Spotify works fine.  


As a premium user, I find this highly problematic and insulting.  I'm obviously not using Adguard DNS to block ads from Spotify.

Oh my God this worked. I completely forgot I had this on. Thanks
Casual Listener

Same problem, and I can confirm this "fixed" my Spotify issue.  I use AdGuard DNS.


I'm not sure how I will proceed here.   As a premium user, I'm not sure why this should matter to Spotify.  AdGuard adds a lot more to my life than Spotify.

Casual Listener

No problem. Spent hours today pulling my hair out with frustration over this and then I remembered I added this DNS recently.


Pretty dumb since as premium users we pay for the privilege to avoid ads