No internet connection/ app shows offline despite on WiFi or data


Hi. For the past few days, I've been completely unable to use spotify on mobile data. I have the allowance to do so but all the tracks are grayed out and I get a "no internet connection" error at the bottom. It works perfectly fine on WiFi.


I have tried:

Uninstalling and reinstalling 

Logging out and back in several times



I have the Premium Student plan and a Samsung Note 10.



Thanks for your patience so far! 


If you're experiencing this, could you make sure to try the following first:


  • Log out and log back in the app with your login details
  • Restart your device
  • Thoroughly reinstall the app with these steps 
  • Use a different connection
  • Check your firewall and antivirus software/apps to make sure Spotify is whitelisted/set as an exception
  • If the issue is happening on mobile data, make sure Spotify has the permission to use data under App Permissions.
  • For Android users: Make sure the Spotify app is closed. Open the following URL in the mobile Chrome browser: chrome://net-internals/#dns and click on DNS (if not already marked). There is a button saying "Clear host cache" - press that button. Next click on Sockets and press "Flush socket pools". Start the Spotify app.
  • For Windows users

    1. Close/exit the Spotify app.
    2. Click on the Start Icon.
    3. Write cmd and open Command Prompt.
    4. The Windows Command Prompt Window will appear. Type in: ipconfig /flushdns and press ENTER.
    5. You should receive the following message: Windows IP Configuration. Successfully flushed the DNS Resolver Cache.
    6. Open the Spotify application.

If the issue persists after that, add your +VOTE to let us know. We'd also recommend making sure that you're rocking the latest update available as our tech teams are looking into this.  If you could provide a video which shows the issue, that'd be great!

We'll keep you posted here on any other updates we have on our end so don't forget to subscribe to this thread

Related Issues


Having the exact same issue on my Galaxy S10e. Super frustrating

Casual Listener

Same problem.  I've tried on a pixel 2 and pixel 3 using both the apk and trying to play through my phone's browser.  The problem appears on both WiFi and Phone data.  Network is working for the phone using WiFi and Phone Data with phone browser, email, other apps on both phones.


Also, I cannot play anything through the browser interface.  Also, using the desktop client (Ubuntu 18), I am getting a message about a firewall problem.  I'm not sure if this is related since I've never used the desktop app before.


Basically, I can't play Spotify on anything.  


I have Premium plan and am in USA.  

Casual Listener
Oh - Some other things I've tried:
1. Logging out
2. Clearing data and cache
3. Uninstalling and reinstalling the latest app onto my phone
In all three cases, once I've logged out, I cannot log back in. Instead I get a message about not being connected to the internet.

So here is a screen shot just so you can actually see it. Full LTE as seen & no connection. 

Casual Listener
This thread is describing the same problem:

This is screen I got. Then I logged out, cleared data, did a complete reinstall, etc. and cannot log back in. "No Internet connection available". Maybe a systematic problem?
Casual Listener

Recently added this private DNS to block ads. This was the issue. Turned it off, and it works now 

Casual Listener

Looks like the problem for me was using Adguard DNS.  If I switch that off, Spotify works fine.  


As a premium user, I find this highly problematic and insulting.  I'm obviously not using Adguard DNS to block ads from Spotify.

Oh my God this worked. I completely forgot I had this on. Thanks
Casual Listener

Same problem, and I can confirm this "fixed" my Spotify issue.  I use AdGuard DNS.


I'm not sure how I will proceed here.   As a premium user, I'm not sure why this should matter to Spotify.  AdGuard adds a lot more to my life than Spotify.

Casual Listener

No problem. Spent hours today pulling my hair out with frustration over this and then I remembered I added this DNS recently.


Pretty dumb since as premium users we pay for the privilege to avoid ads