No internet connection on mobile data

Device: HTC One M9 AT&T

 

Operating System Version: Android 5.1    2.6.502.18

 

Spotify Version: 4.4.0.1008

 

Description:

Spotify won't connect on mobile data.

It does connect well with Wi-Fi

I still have a LOT of data left in my plan for high-speed internet (several GB)

Google Play Music works well for streaming over mobile data

Amazon Music works well for streaming over mobile data

 

 

To reproduce:

  1. Open Spotify and go to "Browse"
  2. It says "You're Offline"

Workaround:

 Use Wi-Fi only.

Can only play offline songs.

 

Additional information:

 I have a Premium subscription

 

Comments
Bittencourt
Rock Star 21
Rock Star 21

There is a similar issue here with a suggested solution that might help you.

 

Hope it works!

 

Oreste
Composer
Status changed to: Closed

Hi errette!

 

Welcome to the Spotify Community, we're glad to see you're part of the band.

 

Just to check, is this happening over 3G or 4G. Also, how long does it display as "Offline" before connecting?

 

Best thing to try here is a reinstall, just follow these steps. Then, restart your device and make sure the app is not set to "Offline Mode" (Settings > Playback). 

 

Let us know how it goes, we'll be right here waiting 🙂

errette
Casual Listener

Problem solved. Uninstalling and reinstalling solved it.

 

It was happening over 4G. The "Offline" display used to last forever. It was not in "offline mode".

 

Thanks for your help!

Pete
Roadie
Status changed to: Closed
 
Thealphafail
Newbie

My phone is still not allowing me to listen on data after reinstalling 4 times. I have unlimited data and this has never been a problem before. 

Chip369
Newbie

I have also had this problem for many months. The app is not set to offline, I have 4G, signal, unlimited data, latest updated app, uninstalled and redownloaded, reset phone. Streaming works fine in other apps, Spotify works fine on wifi. 

shriaviator
Newbie

i have the same problem , using one plus 6 ,network vodafone , chnaged the apn settings to ipv4 only {same needs to saved } then everything works normally . Seems to be a network issue with vodafone , other users on the forum have posted , similiar issues with vodafone 

Related Issues