Help Wizard

Step 1


No play button in podcasts on Android






Galaxy S7 international

Android Oreo,


 Hey, after latest update no play button for podcast episodes only download. Cant play episodes. Thank you for your help.


Finally! I found a fix. 

On my S7 Android Oreo, on the phone's display language setting, I found out there is a way to add a secondary language that kicks in when an app doesn't support your phone's main display language. 

I added English as my secondary and it fixed the missing play button. 

This is still a workaround and Spotify needs to fix its broken app.


hebrew langue.jpg

Hey there folks, 


This should be now fixed! 


If you're still having troubles, we'd recommend trying a quick reinstall of the app on your device.


However, if you're on the latest version of the app and you're still experiencing this, don't hesitate to let us know. Just make sure post in Help if you are, so we can investigate.


Cheers 🙂


Hey Everyone,

Sorry for this issue but I've gotten a couple suggestions you can try:

  • try on another device with your account
  • try on your device with another account
  • try on web player on the Android device

I am hoping that one of these suggestions will help you out, let me know!

Sorry, these suggestion don't work. On the web player I can't find any
podcasts at all, another account doesn't solve the problem, and I still
have the same issue on my tablet (Lenovo 4).
Meanwhile installed Stitcher instead and very happy with it. I would
recommend it to all those who live podcasts.

I have a Huawei P10 Plus, and have the same issue.

I addressed Spotify's support, and the guy in the chat told me there will be a fix in the next update.

My way of overcoming this in the meantime is to add the podcast to the queue, and then go to the queue and tap it. It is somewhat burdensome, and yet the best solution I found so far.

Just that you know, Spotify, it's not just that the play button disappeared, it's the title of the podcast's episode as well...

Status changed to: Under investigation

Hey everyone,


Thanks for raising this issue on the Community and for being patient.


We have reported this to our tech folks who are currently looking into fixing this for you.


In the meantime, if you are experiencing this issue, please make sure to click the +VOTE button and leave a comment with the following details, if you haven't already:

  • Device(s) and OS version
  • Spotify version



Hey there everyone, 


Just to confirm, can you try resizing the text on your devices and let us know how that goes?


You should be able to find this option in your devices' Settings > Accessibility.


We'll be keepin an eye for your replies 🙂

Hey, this isn't working for me.
(Lg g6)
hi, actually i can't find accessibility anywhere in the settings, looked a few times.
i saw that someone tried to solve the problem as offfered but didn't work.
tried deleting the cache. that didn't work too.
hope a solution will be found soon.
  • Since you asked for details here are mine:
  • I have a Samsung S8 woth Android 8.0
  • Spotify is version armV7
  • Still having the issue.
I tried enlarging the text, it didn't make any difference.
Hi! Resizing didn't help. The play button does not reappear. Such a shame.