No play button in podcasts on Android






Galaxy S7 international

Android Oreo,


 Hey, after latest update no play button for podcast episodes only download. Cant play episodes. Thank you for your help.


Finally! I found a fix. 

On my S7 Android Oreo, on the phone's display language setting, I found out there is a way to add a secondary language that kicks in when an app doesn't support your phone's main display language. 

I added English as my secondary and it fixed the missing play button. 

This is still a workaround and Spotify needs to fix its broken app.


hebrew langue.jpg

Hey there folks, 


This should be now fixed! 


If you're still having troubles, we'd recommend trying a quick reinstall of the app on your device.


However, if you're on the latest version of the app and you're still experiencing this, don't hesitate to let us know. Just make sure post in Help if you are, so we can investigate.


Cheers 🙂


Plan: Premium

Country: Israel

Device: Xiaomi 5s

Operating System: Android 7.0 NRD90M

The same. The feature of play/pause control on podcasts is missing.


Smae here, going on for at leats a week.

Device: Samsung Galaxy S7.
Os: Android 8.0.0 Oreo

Spotify: armV7

Hi, I both enlarged the text and reduced it, and the problem remains (no
title for podcasts and no play button).



I also have this problem for at least a month now.

Plan - Free.

Country - Israel.

Device - Samsung Galaxy s9 plus.

Operating System - Android 8.0

Spotify Version - armV7.




I have the same issue (Galaxy s9+).

The problem is using the phone Hebrew language interface, in which the buttons location is messed up and the play button is placed off screen 😞

Work-around: change phone language.

Spotify Dev: come on guys, almost 2019... I thought all right-to-left issues are long solved....

So the problem occurs in RTL languages!
Changing language from Hebrew to English actually does solve the issue. I'm
sure the Spotify devs can solve it in the next update, as it worked fine


Thanks nivtok,

Not only did changing the language to English solve the problem, changing it back to Hebrew seems to have not reversed the solution.

The play button is still visible (For now...) even after changing back to Hebrew.

Anyway, Spotify devs., please get this figured out.

Reversing to Hebrew did reintroduce the issue for me, so it doesn't work
unless the language stays English (or any LtR language).

I have the same problem. 

Im from israel, using samsung 8+