Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Now Playing bar missing on Android

Hey folks,


We have received reports that Android users (mostly Samsung users) are unable to see the Now Playing bar on the app whenever they play songs/podcasts.



If you’re experiencing this issue, make sure to click +VOTE and Subscribe to the thread to be notified of any developments.

Hello everyone,

We've been continuing to gather your details in this thread and further looking into matters.

As mentioned previously, the issue with the now playing bar had been resolved for the majority of users about a month ago. The common denominator with every report received afterwards was that this was still intermittently an issue on Samsung phones. 

There's most likely something within how the affected phones process and handle the Spotify app that still causes the now playing bar to misbehave. We'll continue to work on optimizing the app and trying to find a permanent solution for those affected.

While this is ongoing, we want to thank @Tom0527 for posting steps that provide a solution by modifying some phone settings. Follow the instructions in his post and you shouldn't have any more troubles. 

As we now have enough information, the general fix is in place and there's a device-specific solution, we will be marking this thread as Fixed and closing it. With that being said, we want to reiterate that we'll continue in our efforts to improve stability for all supported phone models from our end as well.

Take care!




I have the same issue. Here is a way to recreate this.


*clean install, reinstall, deleting the system data, changing permissions, everything that are mentioned are already tried*


This is the exactly the same post from here


Spotify has the permissions to run on background. Here is an exact way to recreate this problem.


Device: Galaxy Tab S7 (SMT-1870)

Firmware: Android 12, One UI 4.1, Kernel 4.19, Android security patch (June 1 2022)


Spotify ver:



Remove permissions if app is unsed (off)

Permissions : Near by devices, Remove permissions and free up space (off)

Battery : Unristricted


Spotify-in-app-settings (Devices): show local devices only (on), spotify connect in background (on)


0. Download firefox for android if not done so.

1. Force quit spotify (long press spotify icon, tap info button, and select force quit at the bottom.

2. Open spotify and play some long podcast show such as the one blow

(it could be done with any songs but they occur randomly, but long podcasts tend to give the disappearing now playing symptom consistently).


3. open firefox for android and go to and play some random video. Perhaps this


4. keep the video running for 20~1hr, without pausing the video, press home button at the bottom (□) and go to the homescren. Video will stop.


5. Tap and open spotify, like a magic, now-playing disappears.


6. To recover now playing, you need to force quit spotify.


If someome could recreate the problem following these steps please let Spotify know too.




 currently playing a song but no track bar


Here is a screenshot. In general Spotify glitches much more when reception is poor. Reception shouldn't affect something like the now playing bar or finding downloaded songs. 



I have done the clean reinstall and the now playing bar still continues to go missing and I have to Uninstall the app to stop playing music. It's a frequent annoyance. I really want to keep this app, no one is better than Spotify, but, this is extremely frustrating. Especially because I pay for premium. 


I am on Oneplus Nord Android 11. The now playing bar didn't dissappear, but the album cover art does. Mostly random, but mostly after long idle or playing in the background and  than playing a new track. Selecting another track / album / podcast fixes it most of the time.

I did a clean install a week ago. See me other post.

Latest version.









Samsung Galaxy S22

Operating System

Android 12



I had to clean reinstall 3 times Spotify since I bought this phone 48 hs. ago to have the playing now bar. It is very annoying.



A moderator on other thread (




Suggested this

For the fix.



It gives you insight on why this bug is occuring on Samsung devices.


Tldr: Samsung's puts strong restrictions on apps so they're tech sech look better, especially on battery usage. This is restricting many Apps' functionality.


Samsung S20


I upgraded to the latest version of Spotify tonight and I am now suffering from this problem. It is extremely frustrating!!!


Please sort ASAP. If you need someone to help test, feel free to contact me.



Thanks for your hint to install an older version. However and to be honest: this cannot be a suitable solution...install an old version and do kot update anymore..

At the moment i still do believe that users which are paying for premium version do deserve what they are paying for...meaning listening to music AND beimg able to use the respective app without failures which lead to watinf the users time...just to mention buzzwords like reinstall, clean reinstall, send us this, send us your job and let us do what we are paying for. And do not create frustration. Full stop.

  • Okay I figured out a possible solution for Samsung + Android OS. 12 + One UI version 4.1 (you can check this in Settings -> About tablet (phone) -> Software Information).


It has been two days, and now paying bar is still present, when before doing the following, the bar disappeared in less than one hour!


Spotify ver. 8.7.36


1. Open Settings app.


2. In Settings, go to Apps -> Spotify ->  turn off, remove permissions if App is undesed

3. in the same spotify app settings from (2.), tap battery and select Unrestricted


4. In Settings, go to Battery and device care

5. Tap Battery and Turn off Power saving.

6. In the battery settings (5.), tap Background usage limits, turn off put unused apps to sleep

7. in the same settings as (7.), tap Never sleeping apps, select '+' at the top and add all apps to the list.

8. in the same settings menu as (5.) tap More battery settings and turn off "Adaptive battery" and "protect battery"


9. In the same settings menu as (4.), there are three dots aligned vertically at the very top (︙),  tap this and tap 'automation'. turn off all of them, namely 'Auto optimize daily, Auto restart at set times, Adaptive power saving'.

10. IN the same settings menu as (4.), next to ︙, there will be a stats icon (something like -> .i|), tap that, and at the bottom, turn off Auto optimize.


11. In the same settings menu as (4.), tap Memory  and tap 'Excluded apps', select '+' button on top, and add all apps to the list.

12 in the same settings menu as (4.), turn off device protection.  


13 In Settings app, goto -> Advanced features and make sure Continue apps on other devices is turned on. 


14. In Open Spotify, tap gear option at the top.

15. Turn off Autoplay on other devices, turn on show local devices only, and disable Spotify connect in background.


14. Restart (


If this doesn't work, at least try the procedures after uninstall+clean installing the app. It might be necessary to enable developer options ( and afterwards in the Settings app (at the very bottom) -> developer options (at the very bototm) > background process limit, set this to don't allow background process. If you change this setting, do not reboot. It unfortunately resets after each restart so you'd need to reenable it then.


These steps should disable all the app killing features imposed by Samsung that screws up the Nowplaying bar after some time of inactivity of Spotify's interface.

Maybe put some pressure on Samsung by writing a review on where ever you got the device from, so that Samsung will stop hacking Android that make vital apps as Spotify unsuable. 


Also I am 100% confident that it isn't the fault of Spotify, so don't be angry at Spotify, if i'ts anyone's fault, it's Samsung's. Be angry at them.


You are welcome 🙂