[PS4/Playstation] Spotify wont play every song




Operating System Version:



Spotify Version:

 just updated



I want to play a song on the Playstation app, so I go to a playlist and hit X when being in the coverflow view, sometimes that song starts, sometimes it doesn't. When it does an i go to the next song it very often just pauses and does not continue. And then, when I go to the next song it starts playing the first song for like half a second and then immediately pauses again and so on with the next few songs until it comes to another song that it will play normally. 


To reproduce:

  1. open playlist in ps4 app
  2. start playing (will immediately go back to pause...)
  3. Additional information:

I have shuffle an repeat all enabled

Behaves exactly the same, when playing the music on the ps4 and controlling with the android 6.0 phone


Hey everybody!


Thanks for your patience regarding this issue. We've been given the all-clear from the teams backstage and haven't seen any recent reports on this thread. With this being the case, we're going to be closing this thread as "Fixed".


If you're having issues, please make sure that you're rocking the latest version of Spotify and your PS4 firmware is up-to-date. If after this you're still having issues then please let us know 🙂




No fix in nearly a year, cancelled sub.

I tweeted them waiting on a reply I doubt we will get much luck getting this fixed
At a tenner a month it aint good enough, but from the looks of things they
have no idea how to fix it. Thanks for trying though.

- Pete

Really guys? REALLY????? You STILL can't fix your app on the Playstation. Nice work. I might have to cancel too. 


Same issue here. Shame.

Cancelled my subscription

Same issue here- all of my other devices - PS3, iPhone, iPad work fine on the same wireless network. The Ps4 takes about 30 button presses before it decides to start a song. As I use my ps4 as my main spotify player this is beyond annoying.


Setting my ps4 MTU to 1450 worked for me... It could for you.


The app seems to be working better on PS3, for now.


I haven't changed any of my settings in the console. But one thing I have done is make sure I'm not in private session mode on my phone (I use the app on my phone to control the app on my console). I'm also avoiding my personal playlists and just playing albums/songs off the artists' pages. However, I'm unsure of whether or not this has made a difference or if Spotify has finally fixed whatever was going on. 

Setting MTU to 1450 worked.... I can't believe it. Thanks x 10000000