[Pioneer device] Spotify connect gaps, blanks, and freezes

Device:

Pioneer N-50A-K

 

Operating System Version:

034.035.1010.100 (last Pioneer firmware)

 

Spotify Version:

Spotify connect included in 034.035.1010.100

 

Description:

Random but very frequent gaps and freezes in the music when using Spotify Connect.

Example:  The music will play for a few seconds, sometimes 5s., sometimes 40s.. Then gaps and gaps again, terrible during 20s, before everything seems to be normal again during 10s, and so on...

 

To reproduce:

  1. Start spotify on tablet or phone
  2. Start a music
  3. Ask spotify Connect to stream from the Pionner receiver, and wait for a few seconds

Workaround:

No workaround found at all. Here is what I've tried, without any effect:

  • restarting the Pioneer receiver
  • updating the Pioneer's firmware
  • changing the network config of my Pioneer receiver (static IP or DHCP, auto DNS or Google's one, ...)
  • shutting down other devices on the network (tablet, PC, ...)
  • using other ethernet ports on my router and/or ethernet switch
  • restarting my router

 

 

Additional information:

 

Sorry to post here again; I already detailed the issue in this thread: https://community.spotify.com/t5/Help-Other-Partners-Windows/Spotify-Connect-Denon-Connection-Loss-N... (like a lot of other users experiencing the same problems)

 

However, the above thread is marked as "resolved", so I'm not sure if Spotify staff is still monitoring the replies.

The thing is that the problems has appeared again the last 2 weeks. I thought that making a clear new thread will help everybody to follow the status, adding to the fact that it may be a different problem (different root cause) even if the effects on the users are clearly the same.

 

 

In order to sum-up the situation wih Spotify Connect:

  1. Middle of August: First users report problems with Spotify Connect.
    Music plays for a few seconds, and is then randomly stopped. It seems to impact a lot of receivers (Denon, Marrantz, Pioneer, ...) with different effects depending on the receivers (Network restart on Denons, gaps and pauses on Pioneers, ...).
  2. End of August: Fixed.
    Not a lot of details on what was changed, but it seemed that Spotify acknowledged that there was a problem on their server, and was solved.
  3. Since middle of November: same problems are back again.
    From what I see on this thread: https://community.spotify.com/t5/Help-Other-Partners-Windows/Spotify-Connect-Denon-Connection-Loss-N... , the 2 last pages are filled only by post of peoples experiencing this problem again since mid-November.

Hey everyone, 

First of all we appreciate your patience while our teams looked into this on our end. We’re marking this as closed as we have updated our partners with all the info we can on our side. Should we hear any other news about this or firmware updates to these devices we will post here. 

Thank you folks, we’ll close this thread for now. 

Comments
Guilimote
Music Fan

Hey Spotify!

 

Can you please make an official statement, at least to acknowledge that you are investigating?

 

You service is really enjoyable when it works, but it's terribly frustrating in such cases, added to the fact that Spotify Connect users are premium users!

 

There are more and more reports from people having the same issue in the last few days...

japnl
Regular

I've the same issues with my Pioneer VSX-S510 these days/weeks... 😞

kajko1901
Casual Listener

I have same problem with new marantz mcr 511!!

Rorey
Spotify
Spotify
Status changed to: Closed

Hey @Guilimote. Spotify here. We're getting this looked into. Our apologies for having to wait so long for a reply.  

 

Would you mind adding a bit more detail to what you mean by "gaps"? Does playback pick back up at the same point in the song where it left off? Does it skip ahead to a later point while the music stops? 

 

Also, your most recent version of Spotify would be helpful. Thanks!

 

Guilimote
Music Fan

Thanks for the answer.

 

That's a good question, I can not answer for sure without testing again. I'm not at home for the moment, I will try to give you more info as soon as I can (hopefully tonight).

Guilimote
Music Fan

@Rorey : 

I couldn't test it sooner than yesterday à 10:30 PM...  And like the test I did on Monday at 11:00PM, I couldn't reproduce the issue. Everything worked flawlessly during ~45min. But also like Monday, I'm quite confident that it does not mean that the problem has disappeared, see my post made on Tuesday: https://community.spotify.com/t5/Ongoing-Issues/Connect-Spotify-Connect-Issue/idc-p/1244388#M8555

 

I really have the feeling that it depends on the time of the day (server overload?), because it is 90% - 95% reproductible sooner in the evening, or during the weekend. Moreover, once it is happening, it happens really a lot.

 

The thing I don't understand is: If it is due to a server overload, or a peering problem, or anything related, why is the regular Spotify(ie no "Connect") never impacted? As I said, my PC or Android Tablet on Spotify never ever have the problem. (streaming at max quality)

 

I will try to post more info when I have them.

Rorey
Spotify
Spotify

@Guilimote If you do experience the issue again, try to remember the timestamp so we can investigate. Let me know if the issue reappears. 

Guilimote
Music Fan

Hello @Rorey,

Unfortunately, but as "expected", I reproduced it again. I could not test until yesterday at 11:30 PM, but this time the issue occured even if it was late in the evening.

The frequency of the gaps was not "huge", but it was enough to be a real pain if you just want to relax an enjoy the music. I would say it happened 5 or 6 times per track, each time being a gap of 0.5 to 5s, for a 3min track.

 

DETAILS:

 

Version:

First, you asked me my Spotify version. It happens whatever the controller: I reproduced it with both my PC or my Android tablet used to controll the Pioneer. I haven't checked my PC version, but Spotify is currently 4.2.0.739 on my tablet.
It is this version that I used yesterday.


For my Pioneer receiver, you can check the firmware version in my first post.

 

Time stamps:

Then, to quickly answer your timestamp question: the music seems to be paused during the small gaps or freezes, but it is not reflected visually on the Spotify app.

It can happen randomly in the track, and does not seem to be linked to a specific timestamp.


For more details, here is what happens exactly in terms of timestamp between the controller and the receiver:

 

FULL EXAMPLE:

 

----- Initial state -----
On the Pioneer receiver:

  • Sound: Music is playing and can be heared
  • Play state: Visual indication of "playing" state
  • Progression bar: The playback bar is moving normally and the timestamp is the same as the tablet

On the Android tablet controlling the Pioneer receiver:

  • Play state: Spotify indicates that it is in "playing" state
  • Progression bar: The playback bar is moving normally and the timestamp is the same as the controller

 

----- Freezes can be heared -----

On the Pioneer receiver:

  • Sound: Music is stopped and nothing can be heared for a few seconds
  • Play state: The icon showing the "playing" state disappears. It means that the receiver clearly detects that something is wrong; it doesn't display a "paused" icon either.
  • Progression bar: The playback bar is frozen. The time stamp does not evolve anymore.

On the Android tablet controlling the Pioneer receiver:

  • Play state: Spotify indicates that it is still in "playing" state
  • Progression bar: The playback bar continues to move normally and the timestamp continues to increase (so not in sync anymore with the receiver)

 

----- End of the freeze, music heared again -----
On the Pioneer receiver:

  • Sound: Music can be heared again, and seem to continue where it was "paused"
  • Play state: The icon showing the "playing" state appears again.
  • Progression bar: The playback bar start to move again, starting exatcly where it was paused. Same thing for the timestamp.

On the Android tablet controlling the Pioneer receiver:

  • Play state: Spotify indicates that it is still in "playing" state
  • Playback bar: The playback bar continues to move normally and the timestamp continues to increase (so if the freeze last 5s, the playback bar keeps its 5s advance onto the receiver timestamp)

 

----- Real end of the track is reached -----

On the Pioneer receiver:

  • Sound: End of current track
  • Playback bar: The playback bar reaches the end normally.

On the Android tablet controlling the Pioneer receiver:

  • Playback bar: The playback bar reaches the end in advance, and wait until the receiver also reaches this end. When it is done, the next song is started.

 

OTHER IMPORTANT INFO:

Please note that when the issue is present, there is most of the time an other side effect:
The reaction time to start or pause a song is far longer than usual.
Usually, the playback on the receiver is more or less immediat when a song is selected on the android controller. But when the gap/freeze issue is present, the reaction time can be 1 to 10s...

 

Here is an example I timed yesterday:

  1. A song is playing, the timestamp is 1:02 on the controller AND the receiver.
  2. "Pause" is selected on the Android controller
  3. The playback bar is paused on the Android controller, and the timestamp is frozen at 1:02.
  4. BUT nothig happens on the Pioneer receiver: it is still on playing state, the music continues to be heared, and the playback bar continues to increase: 1:03, 1:04, ... until 1:11
  5. At 1:11 (so nearly 10s late!): the Pioneer receiver finally switches to pause.
  6. On the same time, the progression bar of the Android controller, which was paused at 1:02, jumps to 1:11, like the Pioneer receiver. It stays in "paused" state.


This "long reaction time" is directly linked to the "gaps and freeze" problem; and has never been experienced when Spotify Connect is working correctly (and it has worked correctly for months).

Rorey
Spotify
Spotify
Status changed to: Closed

Thanks @Guilimote. I've reported this and we're investigating. 

Guilimote
Music Fan

@Rorey: Hello! Here is some more information:

 

I have no issue for more than one week now.

However, If you haven't changed anything on your side, I am quite sure that it will appear again. It may be in one week, or two months, I don't know.

But: As I already explained, I had the same issue in August (like many others), and like now, it disappeared by itself in the beginning of September (after ~2/3 weeks).The issue appeared again in november, and has now disapeared again one week ago, so nearly one month later.

For this reason, I really hope that saying that I can't reproduce my problem anymore for now will not mean that you cancel any investigation.

 

The question I would like you to answer, but for which I never had any luck despite the number of time I asked, is the following: I'm sorry to insist, but I would like to understand:

Why is there a difference between the "regular" spotify stream (ie application on PC, tablet, smatphone), and between the "Spotify connect" stream? Are the servers different for a Spotify Connect device than for the regular application?