[Pioneer device] Spotify connect gaps, blanks, and freezes

Device:

Pioneer N-50A-K

 

Operating System Version:

034.035.1010.100 (last Pioneer firmware)

 

Spotify Version:

Spotify connect included in 034.035.1010.100

 

Description:

Random but very frequent gaps and freezes in the music when using Spotify Connect.

Example:  The music will play for a few seconds, sometimes 5s., sometimes 40s.. Then gaps and gaps again, terrible during 20s, before everything seems to be normal again during 10s, and so on...

 

To reproduce:

  1. Start spotify on tablet or phone
  2. Start a music
  3. Ask spotify Connect to stream from the Pionner receiver, and wait for a few seconds

Workaround:

No workaround found at all. Here is what I've tried, without any effect:

  • restarting the Pioneer receiver
  • updating the Pioneer's firmware
  • changing the network config of my Pioneer receiver (static IP or DHCP, auto DNS or Google's one, ...)
  • shutting down other devices on the network (tablet, PC, ...)
  • using other ethernet ports on my router and/or ethernet switch
  • restarting my router

 

 

Additional information:

 

Sorry to post here again; I already detailed the issue in this thread: https://community.spotify.com/t5/Help-Other-Partners-Windows/Spotify-Connect-Denon-Connection-Loss-N... (like a lot of other users experiencing the same problems)

 

However, the above thread is marked as "resolved", so I'm not sure if Spotify staff is still monitoring the replies.

The thing is that the problems has appeared again the last 2 weeks. I thought that making a clear new thread will help everybody to follow the status, adding to the fact that it may be a different problem (different root cause) even if the effects on the users are clearly the same.

 

 

In order to sum-up the situation wih Spotify Connect:

  1. Middle of August: First users report problems with Spotify Connect.
    Music plays for a few seconds, and is then randomly stopped. It seems to impact a lot of receivers (Denon, Marrantz, Pioneer, ...) with different effects depending on the receivers (Network restart on Denons, gaps and pauses on Pioneers, ...).
  2. End of August: Fixed.
    Not a lot of details on what was changed, but it seemed that Spotify acknowledged that there was a problem on their server, and was solved.
  3. Since middle of November: same problems are back again.
    From what I see on this thread: https://community.spotify.com/t5/Help-Other-Partners-Windows/Spotify-Connect-Denon-Connection-Loss-N... , the 2 last pages are filled only by post of peoples experiencing this problem again since mid-November.

Hey everyone, 

First of all we appreciate your patience while our teams looked into this on our end. We’re marking this as closed as we have updated our partners with all the info we can on our side. Should we hear any other news about this or firmware updates to these devices we will post here. 

Thank you folks, we’ll close this thread for now. 

Comments
1164661513
Casual Listener

Same issues appearing for me, started on Sunday and are intermittent and highly variable. watching the download rate its fluctuating quite a bit as though there's simply not enough coming from the server fast enough, everything else through the chrome browser I have no issues at all just spotify app so no issue at my end I'm afraid.

exurbia
Newbie

 

my Premium service is starting to look like a waste of money. I am having many dropouts and crashes, both in web player and my desk top app. It is impossible for me to stream a complete song. My end is no problem I have a very fast (for Australia) connection.

Can anyone suggest a fix? If not I'll just go back to free and listen to internet radio again.

Tidal has no problems, I get fast hi res music from them.

Cheers,

 

Exurbia

jgeusebroek
Newbie

Same exact problem here with a Pioneer VSX-930-K. It is completly random. It happens when controlling from both desktop and mobile.

 

When I use airplay on the same receiver, it works just fine but I prefer to use Spotify connect. This actually is one of the reasons I use a paid spotify account.

rjs70
Casual Listener

Hi I have just joined spotify community .I note that  Spotify connect has been a problem & I am finding the same type of issues.I have a Sangean radio with spotify connect & it did work for a few months.No problems & very impressed .But now I have trouble trying to use my radio with this program.Some time I can be lucky & it works fine .The rest of the time I will click on the icon to choose the radio & all I get is the small screen adverising connect.I cannot get this to work & as I am paying for premium I am very disapointed.

The rest of the internet stations work fine it just seems to be a fault with spotisy connect & it would be great to get it fixed properly.

I have contacted spotify about this problem today

rjs70

Guilimote
Music Fan

Hi,

 

1164661513 (problem using the app), exurbia (problem with the app and the website) and rjs70 (no connection to Spotify), I don't think that your problems are related with mine. You should try to open an other thread on the forum or contact the technical support.

 

To be clear, my issue is blanks and freezes in the sound ONLY when using Spotify Connect on a compatible hardware. Spotify works perfectly if streaming from the app (PC, Android), or from web browser.

 

@Rorey: I have been quiet for nearly 2 months now, because it worked... But, unfortunately, as "expected", the issue appeared again today.

I was sure it would be the case, because it is the 3rd time that this issue appears and disappears from month to month (see my posts on previous page); and there is no reason it won't do it again and again if you don't really fix this issue.

On 30/11/2015, you said that you were investigating... Could you please post here the results or at least the current status of your investigations? Have you anything to communicate?

rjs70
Casual Listener
Hi .I contacted the technical guys & after a couple of emails in an effort
to fix it< all is good .Don`t know what they did but all has been working OK
.

Hope your problems can be sorted out
Guilimote
Music Fan

Hey, I'm sorry, I don't usually do that, but now I'm starting to get really disapointed by the lack of answers ...

 

SPOTIFY

WILL YOU EVER GIVE A TECHNICAL STATUS OF WHAT IS HAPPENING???

 

You can check every of my previous messages, I have always tried to be polite and to be the more precise possible in order to help you, I have given you tons of information, given you every possible technical details, and explained maybe 10 different times why I am sure it doesn't come from my side. Check here and here.

 

I can be rather patient, but now, there has been nearly 7 months since some users first encountered the problem.

It appears, sometimes very badly during 2 weeks, then disappears totally during 2 month, appears from time to time during 2 weeks, and so on...

 

After a week of no problems, again and again, the issue re-appears. Encountered again today.

 

SPOTIFY: The only thing I ask from you is a proof that there is an investigation on your side. Please give us a status, an explanation, a roadmap of the work, other actors you are discuting with and which may be part of the root cause, anything... but give something "technical", other than "dear spotify user, trust us, we are investigating...." and then do nothing!

 

Just to be clear about how much your answers are not consistent:

  • Some people from your technical support said to me that my hardware is not compatible with Spotify Connect (absolutely false, and maybe the worst answer I received)
  • Some people from your technical support said to me that there has been a Spotify update which need a firmware update of my Hardware (absolutely false, Pioneer confirmed that there was nothing like that, and anyway it worked again a few weeks later with no new firmware. Of course the problem re-appeared again later.)
  • I have asked a lot of times some question which never had any answer. I am now sure that you explicitely DON'T WANT TO ANSWER it. Like:is the data stream or the server for Spotify connect different than for regular spotify?
  • And even when you say that you will investigate, there isn't any news of you are doing, and no effect, even after weeks or months. It looks like you're just telling the user what he wants to hear.

 

The feeling is: We Spotify, are selling a service which we now does not wok very well, there may be some peering or servers problems, but, who cares? These guys have paid a high end hi-fi receiver with Spotify integrated in it; so now they are forced to use our service; hahaha, we don't need to care about them as we are sure they will continue to pay for our souscription because they cant change easily their hifi hardware.

 

 

rjs70
Casual Listener
Very frustrating to say the least .We have been fortunate that so far things
are still working .
Rorey
Spotify
Spotify

Hey @Guilimote. Hands in the air! I'm sorry for the radio silence. 

 

We're still investigating yours and other reports. We'll provide an update as soon as we can. 

 

I'd also like to go ahead and get some extra info while I'm at it. (Apologies in advance if this has already been asked somewhere). 

 

Would you mind going to speedtest.net and let me know what sort of bandwidth you have? Also, could you let me know if you're using a WiFi adapter or if you have a regular ethernet connection? 

 

Thanks. 

Guilimote
Music Fan

 

Hey @Rorey,

 

Ok, thanks for the update.

Yes I've already given these kind of info, but no problem to give them again if this time they are read and used by people really investigating.

 

So:

  • Yes, my internet connection is very good. It is an optical fiber from the ISP Orange, in France (Paris). The speedtest I just made gave the following results:
  • I don't use any WiFi adapter between my ISP box and my Pioneer device. It is only ethernet cable.

Moreover, other precisions about why I really don't think the problem comes from bandwidth on my local network:

  • I 've already made a lot of tests on the connections: reseting my router, my ethernet switch, using other ports on my switch.
  • Other devices have no problem at all to use Spotify on the same network. My computer, or even my phone or my Androïd tablet always work perfectly. They continue to work perfectly even with the max quality setting, and moreover my Androïd devices are connected in Wifi.
    The only issue is when using the "Spotify Connect" protocol on my Pioneer HiFi, which is connected in ethernet.
  • I don't think it is hardware related because of the reproducibility: it sometimes work flawlessly during 2 months of intensive usage, and then is not usable during 2 weeks, before working again perfectly. A hardware problem would probably be far more regular.

Related Issues