Help Wizard

Step 1


Pixel 3 USB-C headphones skip function not working






Pixel 3

Operating System

Android 9


My Question or Issue

Double-clicking the pause/play button on the headphones to skip a song does not work. All other functions pause, play, volume work. I'm using the USB-C headphones that came with the Pixel 3. Skip works in other applications like Google Music. I can reproduce the problem with Samsung headphones + USB-C adapter.


Hey folks,


Several of you have reported back saying that setting up Google Assistant resolves the issue. As a result, we'll be closing this thread out.


If you're having trouble setting up Goggle Assistant, please refer to @CJSelf36's reply below, which walks you through the steps.




Hey @CJSelf36,


Thanks for getting back to us with that useful information!


To confirm, are you saying that setting up Google Assistant solved the issue for you?


If so, would you mind providing the steps to set up GA on the Pixel 3 for the other users to try?


Much appreciated 🙂


My Google Assistant is fully set up but still double clicking the button just pauses and resumes the song instead of skipping it.


Either way, looking forward to more info from @CJSelf36 to see if it can be of any help.


Hi Y'all,


Apologies for the delay! Been distracted with festivities...


To answer @Peter's question: Yes setting up Google Assistant did resolve my issue.


When turning on your Pixel 3 for the first time, you'll be asked to setup your Google Assistant during the "Welcoming stage" (as I like to call it..). However, if you're special like me and chose to skip this step, then you will have to go back later on to properly turn on your Google Assistant. The easiest way to achieve this is by downloading the "Google Assistant" app from the playstore.

If you have Google Assistant setup (and working), and the skip function is still failing (@JanisOzolins), then I suggest voice commanding your Google Assistant to skip the song for you (by holding middle button while saying "Please skip the song my dear Google" [Not sure if already mentioned, but AI is much more compliant with kind manners..]) 

After passing the command and successful, try double-clicking to test the skip function. If your command was unsuccessful (and Spotify is currently playing a song on one of your playlists), then your Google Assistant is dysfunctional. In that case, giving feedback to Google is your best choice (Settings/System/About phone/Send feedback about this device).


IF...your Google Assistant is properly setup, and you were able to pass the skip voice command, BUT the skip button is still not working then I suggest the following:

  • Make sure your system is up-to-date
  • Make sure your Spotify app is up-to-date (maybe even try reinstalling the app)
  • Definitely reboot your phone


If no luck after that...then it is truly up to the gods.

As the Late Great Marcus Aurelius once noted, “When the force of circumstances causes you, in some sense, to lose your equilibrium, return to yourself with all speed, and never lose the rhythm for any longer than you must; for you will be more in control of the measure if you return to it again and again.” 


The struggle is always real.











Hey @CJSelf36,


Thanks for providing us with that info! Great stuff 🙂


Could everyone let us know how you get on with this?


We'll be here if you have any other questions.


Take care!

Status changed to: Case Closed

Hey folks,


Several of you have reported back saying that setting up Google Assistant resolves the issue. As a result, we'll be closing this thread out.


If you're having trouble setting up Goggle Assistant, please refer to @CJSelf36's reply below, which walks you through the steps.




Not sure why this thread is closed; the issue is not resolved whatsoever.

The google assistant method literally only works until my Pixel locks. Have to unlock my phone to hold the button to get it to open google assistant - at that point I could just skip the song through the widget... The point is to leave your phone in your pocket.


Huge bug affecting huge amount of people. Phone and app is up to date, reinstalled, etc.

Pixel 3XL /USB-C Pixel Headphones / Anroid 9 / Spotify


I completely agree with you, I have been even thinking of switching to apple music. Spotify seems to have just given up on all of this. I hope they come out with a fix in an update or something. 


Pixel 3 /USB-C Pixel Headphones / Anroid 9 / Spotify


Don't give up hope. I managed to find a bit of a solution.
It's not on Spotify's end, it is indeed how Google manages these headphones through Google assistant.

Likely, if you're like me, you did the Google assistant setup when you first plugged your headphones in, and have tried setting it up again with no luck.

Do this:
Open your assistant in your preferred method.
Tap the little compass logo.
Tap the three dots on the top right and go to settings.
Go to the assistant tab - if you don't see your headphones under devices then you need to add them. I had to restart my phone to get it to allow me to add them.
On top of that - you need to open the headphones when added and allow responses while phone is locked.

Unbelievably, I also had to enable 'allow squeeze for assistant when phone is locked' as well within the phones settings.

After all this, it has been working since. It's incredibly frustrating and a massive oversight that something like this could happen on Google's side, but hopefully something I provided here helps fix it for you.
Unfortunately, the issue likely persists in other music streaming services.



Hi all,

I tried everything and the problem was not solved.

-up to date Pixel 3

-up to date Spotify

-set up Google Assist

Headphone "next song" double click works in all other music sofware but not in Spotify. Not only the Pixel 3 eairbud but any other headset is working a same way for me. 

I tried the "next song please" method with google assisst while holding the middle button. Yes it solved the problem until you restart Spotify.


Please help me, I'am out of ideas.

I still think the problem is at Spotify, because all other audio software can handle the double click method on my Pixel 3 phone.





Hi Sportify-Support,


i think closing this discussion because enabling google assistant solves some things partly does not make sense. What if i do not want to enable google listening to every word i say just to skip a song via my headphones. The problem by the way also occurs for all my other headphones aswell.

So is there any chance to get a proper solution for that?