Pixel 3 USB-C headphones skip function not working

Plan

Premium

Country

US 

Device

Pixel 3

Operating System

Android 9

 

My Question or Issue

Double-clicking the pause/play button on the headphones to skip a song does not work. All other functions pause, play, volume work. I'm using the USB-C headphones that came with the Pixel 3. Skip works in other applications like Google Music. I can reproduce the problem with Samsung headphones + USB-C adapter.

 

Hey folks,

 

Several of you have reported back saying that setting up Google Assistant resolves the issue. As a result, we'll be closing this thread out.

 

If you're having trouble setting up Goggle Assistant, please refer to @CJSelf36's reply below, which walks you through the steps.

 

Thanks! 

CJSelf36
Newbie

Hi Y'all,

 

Apologies for the delay! Been distracted with festivities...

 

To answer @Peter's question: Yes setting up Google Assistant did resolve my issue.

 

When turning on your Pixel 3 for the first time, you'll be asked to setup your Google Assistant during the "Welcoming stage" (as I like to call it..). However, if you're special like me and chose to skip this step, then you will have to go back later on to properly turn on your Google Assistant. The easiest way to achieve this is by downloading the "Google Assistant" app from the playstore.

If you have Google Assistant setup (and working), and the skip function is still failing (@JanisOzolins), then I suggest voice commanding your Google Assistant to skip the song for you (by holding middle button while saying "Please skip the song my dear Google" [Not sure if already mentioned, but AI is much more compliant with kind manners..]) 

After passing the command and successful, try double-clicking to test the skip function. If your command was unsuccessful (and Spotify is currently playing a song on one of your playlists), then your Google Assistant is dysfunctional. In that case, giving feedback to Google is your best choice (Settings/System/About phone/Send feedback about this device).

 

IF...your Google Assistant is properly setup, and you were able to pass the skip voice command, BUT the skip button is still not working then I suggest the following:

  • Make sure your system is up-to-date
  • Make sure your Spotify app is up-to-date (maybe even try reinstalling the app)
  • Definitely reboot your phone

 

If no luck after that...then it is truly up to the gods.

As the Late Great Marcus Aurelius once noted, “When the force of circumstances causes you, in some sense, to lose your equilibrium, return to yourself with all speed, and never lose the rhythm for any longer than you must; for you will be more in control of the measure if you return to it again and again.” 

 

The struggle is always real.

 

HOPE THAT HELPS!

 

HAPPY NEW YEAR!

 

Best,

CJ

 

 

Related Issues

Comments
Moderator
Moderator

Hey @teeeho.

 

Thanks for reaching out to us about this, and apologies for the slow reply! We'll be happy to help you out if you're still experiencing this issue :)

We found a post on the Google forum which has several solutions which seem to have worked for other users. Just head here.

 

Let us know how it goes! If you're still having trouble, let us know and we'll be happy to help you further.

greatish
Newbie

Hi Peter, 

I'm experiencing the same problem to the one described by @teeeho on my Pixel 3 and I have looked into the solution you've suggested. It does work but with one important caveat - once Spotify is closed and launched again or phone restarted I need to perform the workaround again, which is quite inconvenient. Do you think there should be a more permanent solution for this bug?

As a side note, having used Spotify absolutely flawlessly for almost 5 years but on iOS, I'm quite surprised how Android app is so much different and less thought through. 

 

Thanks in advance,

Greta

 

Moderator
Moderator

Hey @greatish.

 

Thanks for reporting this to us.

 

We have passed this information on to our tech folks. As soon as they get back to us with an update, we will let you know in this thread.

 

Thanks again!

Moderator
Moderator

Hey @teeeho and @greatish,

 

Could you try using the headphone with another device and see if the same thing happens?

 

Also, let us know your OS versions and Spotify versions. 

 

Thanks!

 

Oa335
Newbie

I'm having the same issue.  I'm using the Google pixel 3, and have noticed this issue with both the Google pixel earbuds (USB c) as well as Panasonic rptcm125v headphones connected to the pixel 3 USB-c-to-headphone-jack adapter.

Oa335
Newbie

And the Panasonic headphones remote functionality works fine with Spotify on my other device, a Samsung S7

teeeho
Casual Listener

I tested the Pixel 3 USB-C headphones on another device:

Samsung Galaxy S8 / Android 8.0.0 / Spotify v8.4.81.558

The skip does not initially work like on the Pixel 3. I was able to do the workaround of holding the skip button to bring up the Google assistant and speaking "skip song", then the skip button works after that. As @greatish stated, this is only temporary and I also confirmed the issue returns after restarting Spotify or the phone.

 

Back on the original device:

Pixel 3 / Android 9 / Spotify v8.4.81.558

 

The workaround of calling the Google assistant works as well but doesn't require me to speak. I can press the button to call up the assistant, dismiss it, and then the skip button works for that session. Issue returns after Spotify or phone restart.

Moderator
Moderator
Status changed to: Need more info

Hi there!

 

Thanks for reaching out to us!

 

We'd like to further investigate what's going on. We need a few examples to do this so if you haven't sent over the following yet, please do:

 

  • Device and OS
  • Spotify version
  • If it happens with an adapter or without
  • If the headphones work with a different device

Looking forward to your reply!

teeeho
Casual Listener

Hi @Guido, I believe I provided all this information in my most recent comment. Thank you. 

Oa335
Newbie

Any updates on this, I'm honestly about to return my pixel 3. Seems like a minor issue, but it means I have to pick up my phone so much more during the day while at work.  New tech should solve problems, not create them!