Pixel 3 USB-C headphones skip function not working

Status: Closed






Pixel 3

Operating System

Android 9


My Question or Issue

Double-clicking the pause/play button on the headphones to skip a song does not work. All other functions pause, play, volume work. I'm using the USB-C headphones that came with the Pixel 3. Skip works in other applications like Google Music. I can reproduce the problem with Samsung headphones + USB-C adapter.


Hey folks,


Several of you have reported back saying that setting up Google Assistant resolves the issue. As a result, we'll be closing this thread out.


If you're having trouble setting up Goggle Assistant, please refer to @CJSelf36's reply below, which walks you through the steps.



Top Answer

Hi Y'all,


Apologies for the delay! Been distracted with festivities...


To answer @Peter's question: Yes setting up Google Assistant did resolve my issue.


When turning on your Pixel 3 for the first time, you'll be asked to setup your Google Assistant during the "Welcoming stage" (as I like to call it..). However, if you're special like me and chose to skip this step, then you will have to go back later on to properly turn on your Google Assistant. The easiest way to achieve this is by downloading the "Google Assistant" app from the playstore.

If you have Google Assistant setup (and working), and the skip function is still failing (@JanisOzolins), then I suggest voice commanding your Google Assistant to skip the song for you (by holding middle button while saying "Please skip the song my dear Google" [Not sure if already mentioned, but AI is much more compliant with kind manners..]) 

After passing the command and successful, try double-clicking to test the skip function. If your command was unsuccessful (and Spotify is currently playing a song on one of your playlists), then your Google Assistant is dysfunctional. In that case, giving feedback to Google is your best choice (Settings/System/About phone/Send feedback about this device).


IF...your Google Assistant is properly setup, and you were able to pass the skip voice command, BUT the skip button is still not working then I suggest the following:

  • Make sure your system is up-to-date
  • Make sure your Spotify app is up-to-date (maybe even try reinstalling the app)
  • Definitely reboot your phone


If no luck after that...then it is truly up to the gods.

As the Late Great Marcus Aurelius once noted, “When the force of circumstances causes you, in some sense, to lose your equilibrium, return to yourself with all speed, and never lose the rhythm for any longer than you must; for you will be more in control of the measure if you return to it again and again.” 


The struggle is always real.











@Oa335, skip has been working for me lately. I think there was some OS updates pushed recently but I'm not sure if that's the reason. Just started working for me after the last time I setup the assistant with the headphones, even after closing Spotify. 


@Oa335 skip function is also working for me lately and not going away every time Spotify gets closed or phone restarted. Not clear what's the real reason for this fix, but I gotta mention that I have rebooted the phone back to the original settings and setup the headphones and Google assistant once again before I tried using skip function in Spotify. One caveat though: every time I double click the middle button to skip, the current song pauses for a second, then plays again for a moment and only then the next one kicks in. Double clicking faster or slower results in the same outcome. Minor point, but doesn't add to the satisfaction from the product. 




I just purchased the Pixel 3 and am having the same issue with being unable to use the skip function on my headphones. I tried troubleshooting with the recommended workarounds of using google assistant/turning off battery optimization; however, I have had no luck.

If this is a USB-C port issue, I'm more than happy to forward my concerns to Google. I'm just hoping to resolve this issue since the skip function is pivotal...and I love you Spotify too much to ever switch to Pandora...


  • Device and OS:   Pixel 3 running Android 9 (last update 12/05/2018)
  • Spotify version:
  • If it happens with an adapter or without:
    • Yes with both - Pixel Earbuds (USB-C) and Bose Earbuds [Android] (3.5mm + USB-C)
  • If the headphones work with a different device:
    • Yes works with Samsung Galaxy S7

If you need anymore info, always happy to help out.


Thank you for your time and assistance!


This is happening to me on pixel 3 using 3.5mm to USB c headphone adapter. It used to work and only recently (a week or two) started happening.




I am also experiencing the same problem. With the pixel 3 usb c buds. I also have jaybird x3 wireless headphones and the skip song function works fine on those but not on the usb c buds 


Device: Pixel 3

OS: android 9 

Spotify Version:


I hope a fix can be found asap. 

Status changed to: Need more info

Hi there!


Thanks for your patience. We are still investigating this so no worries, we haven't forgot about you!


Before we can proceed, we need to know if other apps do behave how they should.  Could you please try a different app like the built in music player to see if the buttons work fine there?


And in case you haven yet, please send over the following:


  • Device and OS
  • Spotify version
  • If it happens with an adapter or without
  • If the headphones work with a different device

Looking forward to your reply!


I have seinnheise headphones and they have the same problem.  They work perfectly on other phones using Spotify. 


When using the oficial pixel 3 USB C to 3.5mm adapter skip(double tap) doesn't work . Skip works using Google play Music.  So it's a problem with Spotify.


Pixel 3

Official usb c to 3.5 mm dongle 

Android 9

Latest Spotify version. 





Same thing on my Pixel 3, running Android 9 and latest Spotify.


The earbud controls (skipping/next) work fine on all the other apps - Google Music, YouTube etc.



  • Device and OS - Google Pixel 3 and Android 9 Pie
  • Spotify version -
  • If it happens with an adapter or without - without, using the in-box USB Type-C earbuds
  • If the headphones work with a different device - yes, but not on Spotify



I'm having this problem too. 

Here are my stats:


  • Pixel 3, Android 9
  • Spotify version
  • It happens with an adapter and without
  • The headphones work with a different device



Just wanted to give an update:


I've been able to use the skip function in my earbuds. I was intially unable to do so with only the spotify app ( Youtube and other media apps worked ).  When I first purchased the pixel I experienced issues with setting up my google assistant. After recently resolving those issues and properly setting up google assistant, I'm happy to say the skip function has been working.


As flagged by others, the skip function acts slightly delayed ( by continuing to play current song for half a second before switching to the next one ); however, it certainly gets the job done!