Problem local files playlist

Plan

Premium

Country

Germany

Device

Huwaei P10 Lite

Operating System

Android 8.0.0

 

My Question or Issue

 I have recently created a few local playlists on my desktop with songs I have stored on my computer and phone both. They are the exact same songs, because I keep moving new ones to my phone immediately after downloading them on my computer.
These playlists however crash my SpotifyApp on my phone every time I try to open one of them after a short blackscreen. They are visible to me, even with the picture I chose for them individually and it shows that they have the correct amount of songs listed within them. They also work just fine on my computer.
I was wondering wether that was down to how local playlists work or my phone itself and a reply would be much appreciated.

Hey there folks,

 

Thanks for your reports regarding troubles with the Local Files.

 

It looks like there are a couple different issues in this thread. So we can look into this, could you let us know some additional details, for example:

  • The devices you're having troubles with
  • The OS version of your devices
  • The exact version of the Spotify app on each device affected
  • A brief description of the issue
  • Does this persist if you add your local files in a new playlist on your mobile device?

We'd also suggest making sure to:

  • That you're following the steps in this Spotify Answer when adding your Local Files.
  • You've made sure that your Local Files are supported. You can find a list here.
  • Remove any offline devices listed here and then try a clean reinstall of the app on all your devices by following the steps here
  • Try toggling off Hardware Acceleration (on the Desktop app, three dot menu > View > Hardware Acceleration).
  • Try adding your Local Files over a different network connection to see if the issue persists. 
  • Your devices are all up to speed with any firmware or driver software updates. If you see any pending updates, make sure to install them, then try restarting your devices to see if that does the trick.

We'll be keeping an eye out for your replies, thanks!

Related Issues

Comments
daywad
Visitor

Spotify Username

daywad

Plan

Premium

Country

 UK

Operating System

Windows

 

My Question or Issue

When I add my local music files folder as a source, spotify attempts to read the songs then after a few minutes crashes without completing. When I open spotify again the folder has been removed from the list of sources. So I add the folder again and then go to local files, spotify starts reading them and after a few minutes crashes again.

So I can't add any local files to spotify.

The files are fine as I have used them with Spotify previously, I have just moved to them to a new drive.

I found a previous thread regarding this which suggests it might be a memory leakage fault.

I can't add a link but here's the thread

Thread: Memory leak leading to a crash when loading local files
Submitted by bartuszekj on ‎2016-02-26 04:49 AM

Please advise 

Alfredo
Roadie

Hey @daywad.

 

Let's try reinstalling Spotify to see if it helps. If that doesn't do the trick, try launching it as the administrator.

 

You can also try turning off Hardware Acceleration under View to see if it does the trick.

 

All the best.

daywad
Visitor

Thanks, but this has made no difference. I have reinstalled, ran as admin and unchecked hardware acceleration.

 

This is clearly a memory leak problem with the software, attached are screenshots of spotify using more and more memory until it crashes.

 

Since previous unsolved threads about this exist, can I assume spotify doesn't care?

It's currently useless to me as I can't use it as my media player and as a paid service I'm surprised this has not been addressed.

Capture1.JPG
Capture4.JPG
Capture7.JPG
Alfredo
Roadie

I understand!

 

Just to confirm, could you send me your Windows and Spotify version numbers? Also, around how many local files are you trying to add to the app?

 

In the meantime, try splitting the local files in a few folders and adding one folder at a time to see it crashes again.

 

Keep me posted.

daywad
Visitor

Windows 7

Spotify 1.0.80.474.gef6b503e

It's about 100 gig of music.

I would really like this to be useful replacement media player, but not being able to add local files properly due to a unaddressed fault, and with the spotify app not allowing me to play local files to a wireless speaker it's just not any use.

Even the message posting page for this support doesn't work properly, 5 or six times it has deleted everything I write out with a broken message that doesn't tell you why, and then verifaction fails for no reason.

Alfredo
Roadie

No worries!

 

Just to confirm, were you able to try splitting your local files and adding them a batch at a time? Also, do you happen to have a different laptop/desktop you could use to see if it behaves the same?

 

Keep me posted.

Xiokro
Newbie

 

Operating System

OpenSUSE Tumbleweed

 

Issue

 Whenever i try to play local files it gives a ctd, i ran from terminal and i get something along the lines of.

[mp3 @ 0x7fdcc100d380] Skipping 0 bytes of junk at 1291.
Segmentation fault (core dumped)

I read some recent forums and it seems to be a spotify issues with snaps cause Im not the only one to have this problem it seems. But the currently solutions seems to involve things along the lines of installing the Ubuntu Repo version or install from the AUR. The only problem is Im on OpenSUSE Tumbleweed and I dont have access to any of that so Im stuck with snaps for now. This is a big problem for me cause roughly ~40% of my music I use is local files, so I cant listen to the playlists i want to listen to at the moment. If anyone can help me with this issue on OpenSUSE or (hopefully) there is an update to fix this issue. And Ive tried on Stable, Canadite, and Edge releases of the snap.

octoskelo
Newbie

Experienced same issue with following seg fault:

 

[0212/153605.520525:ERROR:object_proxy.cc(615)] Failed to call method: org.freedesktop.UPower.EnumerateDevices: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.AccessDenied: An AppArmor policy prevents this sender from sending this message to this recipient; type="method_call", sender=":1.201" (uid=1000 pid=5209 comm="/snap/spotify/32/usr/share/spotify/spotify " label="snap.spotify.spotify (enforce)") interface="org.freedesktop.UPower" member="EnumerateDevices" error name="(unset)" requested_reply="0" destination="org.freedesktop.UPower" (uid=0 pid=1299 comm="/usr/lib/upower/upowerd " label="unconfined")
[mp3 @ 0x7f73eafad720] Skipping 0 bytes of junk at 130475. [mjpeg @ 0x7f73eac21f00] Changeing bps to 8 [mp3 @ 0x7f73eb050240] Header missing Segmentation fault

 

tomadam
Casual Listener

Hi,I have the same exact problem.

I waste 3 hours but I find the solution, I resolve by replacing the ffmpeg-compat-54 with ffmpeg-compat-57, and now it work.

I hope that this is helpful.

SpencerD0
Newbie

Same problem. I am just glad that I am not the only person experiencing this problem. I am going to give the "ffmpeg-compat-57" solution a try and I will report back here.